Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1581469
| From | "Kershner, David A" <David.Kershner@unisys.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | RE: [PATCH] staging: visorbus, replace init_timer with setup_timer |
| Date | 2017-02-15 18:10 +0100 |
| Message-ID | <tbbfz-2La-3@gated-at.bofh.it> (permalink) |
| References | <tbajw-2bC-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
> -----Original Message----- > From: Jiri Slaby [mailto:jslaby@suse.cz] > Sent: Wednesday, February 15, 2017 11:04 AM > To: Kershner, David A <David.Kershner@unisys.com> > Cc: linux-kernel@vger.kernel.org; Stefan Svinciak <xsvinc1@fi.muni.cz>; Jiri > Slaby <jslaby@suse.cz>; Greg Kroah-Hartman > <gregkh@linuxfoundation.org>; *S-Par-Maintainer > <SParMaintainer@unisys.com>; devel@driverdev.osuosl.org > Subject: [PATCH] staging: visorbus, replace init_timer with setup_timer > > From: Stefan Svinciak <xsvinc1@fi.muni.cz> > > Newer version is more readable and needs less changes if/when > timer_struct is to be changed. > > Signed-off-by: Stefan Svinciak <xsvinc1@fi.muni.cz> > Signed-off-by: Jiri Slaby <jslaby@suse.cz> > Cc: David Kershner <david.kershner@unisys.com> > Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org> > Cc: <sparmaintainer@unisys.com> > Cc: <devel@driverdev.osuosl.org> Acked-by: David Kershner <david.kershner@unisys.com> Looks good and runs nicely on s-Par. David Kershner > --- > drivers/staging/unisys/visorbus/visorbus_main.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/drivers/staging/unisys/visorbus/visorbus_main.c > b/drivers/staging/unisys/visorbus/visorbus_main.c > index aea1aa262b28..55f29ae8e015 100644 > --- a/drivers/staging/unisys/visorbus/visorbus_main.c > +++ b/drivers/staging/unisys/visorbus/visorbus_main.c > @@ -623,9 +623,7 @@ create_visor_device(struct visor_device *dev) > dev->device.release = visorbus_release_device; > /* keep a reference just for us (now 2) */ > get_device(&dev->device); > - init_timer(&dev->timer); > - dev->timer.data = (unsigned long)(dev); > - dev->timer.function = dev_periodic_work; > + setup_timer(&dev->timer, dev_periodic_work, (unsigned long)dev); > > /* > * bus_id must be a unique name with respect to this bus TYPE > -- > 2.11.1
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] staging: visorbus, replace init_timer with setup_timer Jiri Slaby <jslaby@suse.cz> - 2017-02-15 17:10 +0100 RE: [PATCH] staging: visorbus, replace init_timer with setup_timer "Kershner, David A" <David.Kershner@unisys.com> - 2017-02-15 18:10 +0100
csiph-web