Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1580563

Re: [PATCH] Power: Supply: sbs-charger: simplfied bool function

From Joe Perches <joe@perches.com>
Newsgroups linux.kernel
Subject Re: [PATCH] Power: Supply: sbs-charger: simplfied bool function
Date 2017-02-14 15:10 +0100
Message-ID <taLXP-2S6-5@gated-at.bofh.it> (permalink)
References <taLEu-2wc-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, 2017-02-14 at 14:43 +0100, Daniel Perez wrote:
> Simplified the syntax of a simple bool return value function.
> 
> Signed-off-by: Daniel Perez <danielperezdeandres@gmail.com>
> ---
>  drivers/power/supply/sbs-charger.c | 5 +----
>  1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/power/supply/sbs-charger.c b/drivers/power/supply/sbs-charger.c
> index 353765a..3e40553 100644
> --- a/drivers/power/supply/sbs-charger.c
> +++ b/drivers/power/supply/sbs-charger.c
> @@ -137,10 +137,7 @@ static enum power_supply_property sbs_properties[] = {
>  
>  static bool sbs_readable_reg(struct device *dev, unsigned int reg)
>  {
> -	if (reg < SBS_CHARGER_REG_SPEC_INFO)
> -		return false;
> -	else
> -		return true;
> +	return reg < SBS_CHARGER_REG_SPEC_INFO ? false : true;

Any ternary with true false could be simplified.
Why not just

	return reg >= SBS_CHARGER_REG_SPEC_INFO;

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] Power: Supply: sbs-charger: simplfied bool function Daniel Perez <danielperezdeandres@gmail.com> - 2017-02-14 14:50 +0100
  Re: [PATCH] Power: Supply: sbs-charger: simplfied bool function Joe Perches <joe@perches.com> - 2017-02-14 15:10 +0100

csiph-web