Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1677754
| From | Ludovic Desroches <ludovic.desroches@microchip.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH 2/3] drivers: misc: eeprom: at24: support reading mac eeprom from different addresses |
| Date | 2017-06-29 15:40 +0200 |
| Message-ID | <tXHPP-8aI-13@gated-at.bofh.it> (permalink) |
| References | <tXFXH-6YG-5@gated-at.bofh.it> <tXFXJ-6YG-33@gated-at.bofh.it> <tXGh3-774-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Jun 29, 2017 at 02:56:03PM +0300, Andy Shevchenko wrote: > On Thu, Jun 29, 2017 at 2:39 PM, Claudiu Beznea > <claudiu.beznea@microchip.com> wrote: > > Add support for reading from different offsets of EEPROM. > > The offset is initialized via device tree. If nothing is > > given as input the old value, 0x90, is used. In this way > > the driver could be used as generic driver for different > > vendor memories by only changing the reading offset via > > device tree. > > > + err = device_property_read_u8(dev, "start-offset", &chip->offset); > > This property has to be documented. > > Moreover, the name looks too broad (I checked current use of > "*-offset" type of properties and they either vendor specific, or data > type specific. > > Taking above into consideration mac-offset sounds better to me. I agree, it sounds better to me too. Regards Ludovic
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC PATCH 2/3] drivers: misc: eeprom: at24: support reading mac eeprom from different addresses Claudiu Beznea <claudiu.beznea@microchip.com> - 2017-06-29 13:40 +0200
Re: [RFC PATCH 2/3] drivers: misc: eeprom: at24: support reading mac eeprom from different addresses Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-06-29 14:00 +0200
Re: [RFC PATCH 2/3] drivers: misc: eeprom: at24: support reading mac eeprom from different addresses Ludovic Desroches <ludovic.desroches@microchip.com> - 2017-06-29 15:40 +0200
Re: [RFC PATCH 2/3] drivers: misc: eeprom: at24: support reading mac eeprom from different addresses David Lechner <david@lechnology.com> - 2017-06-29 18:20 +0200
Re: [RFC PATCH 2/3] drivers: misc: eeprom: at24: support reading mac eeprom from different addresses Uwe Kleine-König <u.kleine-koenig@pengutronix.de> - 2017-06-30 09:30 +0200
csiph-web