Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1676141
| From | Eric Anholt <eric@anholt.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0/8] RPi touchscreen panel driver v4 |
| Date | 2017-06-27 22:10 +0200 |
| Message-ID | <tX4Ou-5bs-11@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
The review for v3 was basically "no, the panel should probe first so that we have the connector by the time KMS is done initializing." To do this, I needed to be able to register the custom (non-OF-generated) DSI device without the host being present (patch 6). Also check out patch 4 for a new cleanup to panel-bridge. Eric Anholt (8): drm/vc4: Fix DSI T_INIT timing. drm/vc4: Fix misleading name of the continuous flag. drm/vc4: Use drm_mode_vrefresh() in DSI fixup, in case vrefresh is 0. drm/bridge: Add a devm_ allocator for panel bridge. drm/vc4: Delay DSI host registration until the panel has probed. drm: Allow DSI devices to be registered before the host registers. dt-bindings: Document the Raspberry Pi Touchscreen nodes. drm/panel: Add support for the Raspberry Pi 7" Touchscreen. .../panel/raspberrypi,7inch-touchscreen.txt | 49 ++ drivers/gpu/drm/bridge/panel.c | 30 ++ drivers/gpu/drm/drm_mipi_dsi.c | 49 +- drivers/gpu/drm/panel/Kconfig | 8 + drivers/gpu/drm/panel/Makefile | 1 + .../gpu/drm/panel/panel-raspberrypi-touchscreen.c | 505 +++++++++++++++++++++ drivers/gpu/drm/vc4/vc4_dsi.c | 64 +-- include/drm/drm_bridge.h | 3 + include/drm/drm_mipi_dsi.h | 3 + 9 files changed, 671 insertions(+), 41 deletions(-) create mode 100644 Documentation/devicetree/bindings/display/panel/raspberrypi,7inch-touchscreen.txt create mode 100644 drivers/gpu/drm/panel/panel-raspberrypi-touchscreen.c -- 2.11.0
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0/8] RPi touchscreen panel driver v4 Eric Anholt <eric@anholt.net> - 2017-06-27 22:10 +0200
[PATCH 7/8] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Eric Anholt <eric@anholt.net> - 2017-06-27 22:10 +0200
[PATCH 2/8] drm/vc4: Fix misleading name of the continuous flag. Eric Anholt <eric@anholt.net> - 2017-06-27 22:10 +0200
Re: [PATCH 2/8] drm/vc4: Fix misleading name of the continuous flag. Andrzej Hajda <a.hajda@samsung.com> - 2017-06-29 11:10 +0200
[PATCH 8/8] drm/panel: Add support for the Raspberry Pi 7" Touchscreen. Eric Anholt <eric@anholt.net> - 2017-06-27 22:10 +0200
csiph-web