Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1672082
| From | Tahsin Erdogan <tahsin@google.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v5 27/28] ext4: xattr inode deduplication |
| Date | 2017-06-21 23:40 +0200 |
| Message-ID | <tUVvY-3sm-35@gated-at.bofh.it> (permalink) |
| References | <tUnkF-6DB-81@gated-at.bofh.it> <tUnkF-6DB-79@gated-at.bofh.it> <tUVcD-3k9-51@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
> Tashin, we are already using the "no_mbcache" option name, so would prefer > to keep that working. It would be OK to accept both option names to mean > the same thing, and only document the "nombcache" option. Updated patch to accept both nombcache and no_mbcache. >> struct mb_cache *s_mb_cache; >> + struct mb_cache *s_ea_inode_cache; > > These names should be consistent, like "s_ea_block_cache". Yes, I will rename this to s_ea_block_cache. >> #define EXT4_GET_MB_CACHE(inode) (((struct ext4_sb_info *) \ >> inode->i_sb->s_fs_info)->s_mb_cache) >> >> +#define EA_INODE_CACHE(inode) (((struct ext4_sb_info *) \ >> + inode->i_sb->s_fs_info)->s_ea_inode_cache) > > These names should be consistent, like EXT4_GET_EA_CACHE() or maybe > EXT4_GET_EA_BLOCK_CACHE() and EXT4_GET_EA_INODE_CACHE(). How about EA_BLOCK_CACHE() and EA_INODE_CACHE() to keep them short?
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH v5 27/28] ext4: xattr inode deduplication Andreas Dilger <adilger@dilger.ca> - 2017-06-21 23:20 +0200
Re: [PATCH v5 27/28] ext4: xattr inode deduplication Tahsin Erdogan <tahsin@google.com> - 2017-06-21 23:40 +0200
Re: [PATCH v5 27/28] ext4: xattr inode deduplication Andreas Dilger <adilger@dilger.ca> - 2017-06-21 23:50 +0200
csiph-web