Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1671975
| From | tndave <tushar.n.dave@oracle.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: clean up and modularize arch dma_mapping interface V2 |
| Date | 2017-06-21 21:30 +0200 |
| Message-ID | <tUTua-26o-19@gated-at.bofh.it> (permalink) |
| References | <tT40F-3II-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 06/16/2017 11:10 AM, Christoph Hellwig wrote: > Hi all, > > for a while we have a generic implementation of the dma mapping routines > that call into per-arch or per-device operations. But right now there > still are various bits in the interfaces where don't clearly operate > on these ops. This series tries to clean up a lot of those (but not all > yet, but the series is big enough). It gets rid of the DMA_ERROR_CODE > way of signaling failures of the mapping routines from the > implementations to the generic code (and cleans up various drivers that > were incorrectly using it), and gets rid of the ->set_dma_mask routine > in favor of relying on the ->dma_capable method that can be used in > the same way, but which requires less code duplication. Chris, Thanks for doing this. So archs can still have their own definition for dma_set_mask() if HAVE_ARCH_DMA_SET_MASK is y? (and similarly for dma_set_coherent_mask() when CONFIG_ARCH_HAS_DMA_SET_COHERENT_MASK is y) Any plan to change these? I'm in a process of making some changes to SPARC iommu so it would be good to know. Thanks. -Tushar > > I've got a good number of reviews last time, but a few are still missing. > I'd love to not have to re-spam everyone with this patchbomb, so early > ACKs (or complaints) are welcome. > > I plan to create a new dma-mapping tree to collect all this work. > Any volunteers for co-maintainers, especially from the iommu gang? > > The whole series is also available in git: > > git://git.infradead.org/users/hch/misc.git dma-map > > Gitweb: > > http://git.infradead.org/users/hch/misc.git/shortlog/refs/heads/dma-map > > Changes since V1: > - remove two lines of code from arm dmabounce > - a few commit message tweaks > - lots of ACKs >
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: clean up and modularize arch dma_mapping interface V2 tndave <tushar.n.dave@oracle.com> - 2017-06-21 21:30 +0200
Re: clean up and modularize arch dma_mapping interface V2 Christoph Hellwig <hch@lst.de> - 2017-06-24 09:20 +0200
Re: clean up and modularize arch dma_mapping interface V2 Benjamin Herrenschmidt <benh@kernel.crashing.org> - 2017-06-24 17:40 +0200
Re: clean up and modularize arch dma_mapping interface V2 Christoph Hellwig <hch@lst.de> - 2017-06-26 11:50 +0200
Re: clean up and modularize arch dma_mapping interface V2 tndave <tushar.n.dave@oracle.com> - 2017-06-27 00:10 +0200
csiph-web