Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1668709

Re: [PATCH v3 01/14] x86, uaccess: introduce copy_from_iter_flushcache for pmem / cache-bypass operations

From Dan Williams <dan.j.williams@intel.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 01/14] x86, uaccess: introduce copy_from_iter_flushcache for pmem / cache-bypass operations
Date 2017-06-19 04:10 +0200
Message-ID <tTUiB-4Mk-3@gated-at.bofh.it> (permalink)
References <tQyRj-6b1-3@gated-at.bofh.it> <tQyRk-6b1-33@gated-at.bofh.it> <tTDKN-2Hw-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sun, Jun 18, 2017 at 1:28 AM, Christoph Hellwig <hch@lst.de> wrote:
> On Fri, Jun 09, 2017 at 01:23:51PM -0700, Dan Williams wrote:
>> Implement a __copy_from_user_inatomic_flushcache, memcpy_page_flushcache, and
>> memcpy_flushcache, that guarantee that the destination buffer is not dirty in
>> the cpu cache on completion. The new copy_from_iter_flushcache and sub-routines
>
> Wouldn't writethrough be a better name?

I started with _writethrough, Ingo suggested _wt, and then Toshi
rightly pointed out that _wt might lead applications to assume that
the involved cache-lines are valid on return which may not be true. So
we settled on _flushcache in this thread [1].

[1]: https://lkml.org/lkml/2017/5/6/99

>> will be used to replace the "pmem api" (include/linux/pmem.h +
>> arch/x86/include/asm/pmem.h). The availability of copy_from_iter_flushcache()
>> and memcpy_flushcache() are gated by the CONFIG_ARCH_HAS_UACCESS_FLUSHCACHE
>> config symbol, and fallback to copy_from_iter_nocache() and plain memcpy()
>> otherwise.
>
> What is UACCESS about memcpy_flushcache?

The uaccess part comes from the fact that the conversion provides all
the _flushcache versions of the copy_from_iter() operations
(__copy_from_user_flushcache, memcpy_page_flushcache,
memcpy_flushcache). It also stems from Al asking that
__copy_user_flushcache() live in arch/x86/lib/usercopy_64.c. That
said, I wouldn't object to a different name for the config symbol.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v3 00/14] pmem: stop abusing __copy_user_nocache(),  and other reworks Dan Williams <dan.j.williams@intel.com> - 2017-06-09 22:40 +0200
  [PATCH v3 11/14] libnvdimm, pmem: fix persistence warning Dan Williams <dan.j.williams@intel.com> - 2017-06-09 22:40 +0200
  [PATCH v3 04/14] dax,  pmem: introduce an optional 'flush' dax_operation Dan Williams <dan.j.williams@intel.com> - 2017-06-09 22:40 +0200
    Re: [PATCH v3 04/14] dax, pmem: introduce an optional 'flush'  dax_operation Jan Kara <jack@suse.cz> - 2017-06-14 13:00 +0200
  [PATCH v3 01/14] x86,  uaccess: introduce copy_from_iter_flushcache for pmem /  cache-bypass operations Dan Williams <dan.j.williams@intel.com> - 2017-06-09 22:40 +0200
    Re: [PATCH v3 01/14] x86, uaccess: introduce         copy_from_iter_flushcache for pmem / cache-bypass operations Christoph Hellwig <hch@lst.de> - 2017-06-18 10:30 +0200
      Re: [PATCH v3 01/14] x86, uaccess: introduce copy_from_iter_flushcache  for pmem / cache-bypass operations Dan Williams <dan.j.williams@intel.com> - 2017-06-19 04:10 +0200

csiph-web