Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1667427

Re: [PATCH v7 16/16] mtd: nand: denali: avoid magic numbers and rename for clarification

From Masahiro Yamada <yamada.masahiro@socionext.com>
Newsgroups linux.kernel
Subject Re: [PATCH v7 16/16] mtd: nand: denali: avoid magic numbers and rename for clarification
Date 2017-06-16 07:40 +0200
Message-ID <tSS9b-4gj-1@gated-at.bofh.it> (permalink)
References <tRUmJ-ap-9@gated-at.bofh.it> <tRUmK-ap-49@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


2017-06-13 22:45 GMT+09:00 Masahiro Yamada <yamada.masahiro@socionext.com>:
> Introduce some macros and helpers to avoid magic numbers and
> rename macros/functions for clarification.
>
> - We see '| 2' in several places.  This means Data Cycle in MAP11 mode.
>   The Denali User's Guide says bit[1:0] of MAP11 is like follows:
>
>   b'00 = Command Cycle
>   b'01 = Address Cycle
>   b'10 = Data Cycle
>
>   So, this commit added DENALI_MAP11_{CMD,ADDR,DATA} macros.
>
> - We see 'denali->flash_mem + 0x10' in several places, but 0x10 is a
>   magic number.  Actually, this accesses the data port of the Host
>   Data/Command Interface.  So, this commit added DENALI_HOST_DATA.
>   On the other hand, 'denali->flash_mem' gets access to the address
>   port, so DENALI_HOST_ADDR was also added.
>
> - We see 'index_addr(denali, cmd, 0x1)' in denali_erase(), but 0x1
>   is a magic number.  0x1 means the erase operation.  Replace 0x1
>   with DENALI_ERASE.
>
> - Rename index_addr() to denali_host_write() for clarification
>
> - Denali User's Guide says MAP{00,01,10,11} for access mode.  Match
>   the macros with terminology in the IP document.
>
> - Rename struct members as follows:
>   flash_bank   -> active_bank    (currently selected bank)
>   flash_reg    -> reg            (base address of registers)
>   flash_mem    -> host           (base address of host interface)
>   devnum       -> devs_per_cs    (devices connected in parallel)
>   bbtskipbytes -> oob_skip_bytes (number of bytes to skip in OOB)
>
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
> ---
>
> Changes in v7: None
> Changes in v6:
>   - Newly added
>
> Changes in v5: None
> Changes in v4: None
> Changes in v3: None
> Changes in v2: None


Please let me update 18.  (only typo fix)

I sent v8 for this one.


-- 
Best Regards
Masahiro Yamada

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v7 16/16] mtd: nand: denali: avoid magic numbers and rename for clarification Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-06-13 15:50 +0200
  Re: [PATCH v7 16/16] mtd: nand: denali: avoid magic numbers and  rename for clarification Masahiro Yamada <yamada.masahiro@socionext.com> - 2017-06-16 07:40 +0200

csiph-web