Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1651628
| From | Liam Breck <liam@networkimprov.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 2/4] power: supply: core: add charging voltage/current battery info |
| Date | 2017-05-27 03:30 +0200 |
| Message-ID | <tLyIj-4Vw-41@gated-at.bofh.it> (permalink) |
| References | <tLli1-57l-5@gated-at.bofh.it> <tLli2-57l-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Enric,
I'll also incorporate these changes into v14 of my patchset. (See my prev msg.)
On Fri, May 26, 2017 at 4:04 AM, Enric Balletbo i Serra
<enric.balletbo@collabora.com> wrote:
> Add the parameters to define the battery charging voltage and charging
> current. Charger driver can get this information from the struct
> power_supply_battery_info and apply the desired value.
>
> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
> ---
> Changes since v2:
> - Requested by Sebastian Reichel
> - Move to its own patch and apply to simple-battery framework.
> Changes since v1:
> - Requested by Rob Herring
> - Rename ti,charge-* to charge-* to be standard properties.
> - Use unit suffixes as per bindings/property-units.txt
>
> drivers/power/supply/power_supply_core.c | 6 ++++++
> include/linux/power_supply.h | 2 ++
> 2 files changed, 8 insertions(+)
>
> diff --git a/drivers/power/supply/power_supply_core.c b/drivers/power/supply/power_supply_core.c
> index 862fa8fc..a6857c2 100644
> --- a/drivers/power/supply/power_supply_core.c
> +++ b/drivers/power/supply/power_supply_core.c
> @@ -530,6 +530,8 @@ int power_supply_get_battery_info(struct power_supply *psy,
> info->energy_full_design_uwh = -EINVAL;
> info->charge_full_design_uah = -EINVAL;
> info->voltage_min_design_uv = -EINVAL;
> + info->charge_voltage_uv = -EINVAL;
> + info->charge_current_ua = -EINVAL;
>
> if (!psy->of_node) {
> dev_warn(&psy->dev, "%s currently only supports devicetree\n",
> @@ -559,6 +561,10 @@ int power_supply_get_battery_info(struct power_supply *psy,
> &info->charge_full_design_uah);
> of_property_read_u32(battery_np, "voltage-min-design-microvolt",
> &info->voltage_min_design_uv);
> + of_property_read_u32(battery_np, "charge-voltage-microvolt",
> + &info->charge_voltage_uv);
> + of_property_read_u32(battery_np, "charge-current-microamp",
> + &info->charge_current_ua);
>
> return 0;
> }
> diff --git a/include/linux/power_supply.h b/include/linux/power_supply.h
> index 8220f7b..3eea323 100644
> --- a/include/linux/power_supply.h
> +++ b/include/linux/power_supply.h
> @@ -302,6 +302,8 @@ struct power_supply_battery_info {
> int energy_full_design_uwh; /* microWatt-hours */
> int charge_full_design_uah; /* microAmp-hours */
> int voltage_min_design_uv; /* microVolts */
> + int charge_voltage_uv; /* microVolts */
> + int charge_current_ua; /* microAmp */
> };
>
> extern struct atomic_notifier_head power_supply_notifier;
> --
> 2.9.3
>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Enric Balletbo i Serra <enric.balletbo@collabora.com> - 2017-05-26 13:10 +0200
[PATCH v3 4/4] power: tps65217_charger: add support for NTC type, voltage and current charge Enric Balletbo i Serra <enric.balletbo@collabora.com> - 2017-05-26 13:10 +0200
Re: [PATCH v3 4/4] power: tps65217_charger: add support for NTC type, voltage and current charge Liam Breck <liam@networkimprov.net> - 2017-05-27 03:30 +0200
[PATCH v3 2/4] power: supply: core: add charging voltage/current battery info Enric Balletbo i Serra <enric.balletbo@collabora.com> - 2017-05-26 13:10 +0200
Re: [PATCH v3 2/4] power: supply: core: add charging voltage/current battery info Liam Breck <liam@networkimprov.net> - 2017-05-27 03:30 +0200
Re: [PATCH v3 2/4] power: supply: core: add charging voltage/current battery info Enric Balletbo Serra <eballetbo@gmail.com> - 2017-05-27 22:20 +0200
[PATCH v3 3/4] dt-bindings: power: tps65217_charger: add NTC type for battery temperature measurement. Enric Balletbo i Serra <enric.balletbo@collabora.com> - 2017-05-26 13:10 +0200
Re: [PATCH v3 3/4] dt-bindings: power: tps65217_charger: add NTC type for battery temperature measurement. Liam Breck <liam@networkimprov.net> - 2017-05-27 03:30 +0200
Re: [PATCH v3 3/4] dt-bindings: power: tps65217_charger: add NTC type for battery temperature measurement. Enric Balletbo Serra <eballetbo@gmail.com> - 2017-05-27 22:20 +0200
Re: [PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Liam Breck <liam@networkimprov.net> - 2017-05-27 03:30 +0200
Re: [PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Enric Balletbo Serra <eballetbo@gmail.com> - 2017-05-27 22:20 +0200
Re: [PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Liam Breck <liam@networkimprov.net> - 2017-06-01 09:10 +0200
Re: [PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Enric Balletbo Serra <eballetbo@gmail.com> - 2017-06-01 10:20 +0200
Re: [PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Liam Breck <liam@networkimprov.net> - 2017-06-01 12:30 +0200
Re: [PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Enric Balletbo Serra <eballetbo@gmail.com> - 2017-06-01 12:40 +0200
Re: [PATCH v3 1/4] dt-bindings: power: supply: add battery charge voltage/current Rob Herring <robh@kernel.org> - 2017-05-31 21:00 +0200
csiph-web