Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1650273
| From | Jiri Olsa <jolsa@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 11/13] perf header: change FEAT_OP* macros |
| Date | 2017-05-25 10:10 +0200 |
| Message-ID | <tKW0j-5FH-23@gated-at.bofh.it> (permalink) |
| References | <tKcTv-a4-3@gated-at.bofh.it> <tKcTx-a4-41@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, May 23, 2017 at 12:48:51AM -0700, David Carrillo-Cisneros wrote:
SNIP
> -#define FEAT_OPA(n, func) \
> - [n] = { .name = #n, .write = write_##func, .print = print_##func }
> -#define FEAT_OPP(n, func) \
> - [n] = { .name = #n, .write = write_##func, .print = print_##func, \
> - .process = process_##func }
> -#define FEAT_OPF(n, func) \
> - [n] = { .name = #n, .write = write_##func, .print = print_##func, \
> - .process = process_##func, .full_only = true }
> +#define FEAT_OPR(n, func, __full_only) \
> + [HEADER_##n] = { \
> + .name = __stringify(HEADER_##n), \
> + .write = write_##func, \
> + .print = print_##func, \
> + .full_only = __full_only, \
> + .process = process_##func, \
> + .has_record = true \
> + }
> +
> +#define FEAT_OPN(n, func, __full_only) \
> + [HEADER_##n] = { \
> + .name = __stringify(HEADER_##n), \
> + .write = write_##func, \
> + .print = print_##func, \
> + .full_only = __full_only, \
> + .process = process_##func \
> + }
could you please align this (and in other places of the patchset), like:
.name = __stringify(HEADER_##n), \
.write = write_##func, \
.print = print_##func, \
.full_only = __full_only, \
.process = process_##func \
much more readable..
thanks,
jirka
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 00/13] perf tool: add meta-data header support for pipe-mode David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
[PATCH v2 09/13] perf header: use struct feat_fd in read header records David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
[PATCH v2 12/13] perf tool: add show_feature_header to perf_tool David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
[PATCH v2 06/13] perf header: add struct feat_fd for write David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
Re: [PATCH v2 06/13] perf header: add struct feat_fd for write Jiri Olsa <jolsa@redhat.com> - 2017-05-25 10:10 +0200
Re: [PATCH v2 06/13] perf header: add struct feat_fd for write David Carrillo-Cisneros <davidcc@google.com> - 2017-06-05 04:00 +0200
[PATCH v2 03/13] perf header: fail on write_padded error David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
[PATCH v2 11/13] perf header: change FEAT_OP* macros David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
Re: [PATCH v2 11/13] perf header: change FEAT_OP* macros Jiri Olsa <jolsa@redhat.com> - 2017-05-25 10:10 +0200
Re: [PATCH v2 11/13] perf header: change FEAT_OP* macros Jiri Olsa <jolsa@redhat.com> - 2017-05-25 10:20 +0200
Re: [PATCH v2 11/13] perf header: change FEAT_OP* macros David Carrillo-Cisneros <davidcc@google.com> - 2017-06-05 04:20 +0200
[PATCH v2 01/13] perf header: encapsulate read and swap David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
Re: [PATCH v2 01/13] perf header: encapsulate read and swap Namhyung Kim <namhyung@kernel.org> - 2017-05-24 17:40 +0200
Re: [PATCH v2 01/13] perf header: encapsulate read and swap David Carrillo-Cisneros <davidcc@google.com> - 2017-06-05 01:20 +0200
Re: [PATCH v2 01/13] perf header: encapsulate read and swap Jiri Olsa <jolsa@redhat.com> - 2017-05-25 10:10 +0200
Re: [PATCH v2 01/13] perf header: encapsulate read and swap David Carrillo-Cisneros <davidcc@google.com> - 2017-06-05 01:30 +0200
[PATCH v2 05/13] perf header: revamp do_write David Carrillo-Cisneros <davidcc@google.com> - 2017-05-23 10:00 +0200
Re: [PATCH v2 05/13] perf header: revamp do_write Jiri Olsa <jolsa@redhat.com> - 2017-05-25 10:20 +0200
Re: [PATCH v2 05/13] perf header: revamp do_write David Carrillo-Cisneros <davidcc@google.com> - 2017-06-05 04:30 +0200
csiph-web