Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1644648

Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes.

Path csiph.com!eternal-september.org!feeder.eternal-september.org!aioe.org!bofh.it!news.nic.it!robomod
From Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes.
Date Thu, 18 May 2017 17:00:02 +0200
Message-ID <tIv4e-47X-29@gated-at.bofh.it> (permalink)
References <tG69X-4C8-3@gated-at.bofh.it> <tHPHI-IC-13@gated-at.bofh.it> <tIoYN-7HX-5@gated-at.bofh.it>
X-Original-To Archit Taneja <architt@codeaurora.org>
Dkim-Signature v=1; a=rsa-sha256; c=relaxed/simple; d=ideasonboard.com; s=mail; t=1495119308; bh=BNzIaXbPdHRC9i75Xj0/SQ1CpISY6qlo7gvKUdm4tG4=; h=From:To:Cc:Subject:Date:In-Reply-To:References:From; b=XW1uhT4a0qQ8I0Ro7lo2YwV7DXdo/402r1rkvtxtrSGVaUf5FF2chPjV3hhJiYffU +W5bel9z8loC95caLpiH1gcwO/pFdsRcoakQn1lrXn7FOUQz9ojPQIi/ZSwl1/73qw +nd/AA3WHWJ/+3i+b+Y/F2pqYqgE4ReUkuvOvWGw=
User-Agent KMail/4.14.10 (Linux/4.9.16-gentoo; KDE/4.14.32; x86_64; ; )
MIME-Version 1.0
Content-Transfer-Encoding 7Bit
Content-Type text/plain; charset="us-ascii"
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 144
Organization linux.* mail to news gateway
X-Original-Cc Eric Anholt <eric@anholt.net>, Rob Herring <robh+dt@kernel.org>, dri-devel <dri-devel@lists.freedesktop.org>, Thierry Reding <thierry.reding@gmail.com>, Mark Rutland <mark.rutland@arm.com>, Andrzej Hajda <a.hajda@samsung.com>, "devicetree@vger.kernel.org" <devicetree@vger.kernel.org>, "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
X-Original-Date Thu, 18 May 2017 17:55:25 +0300
X-Original-Message-ID <3771766.1sVmoPRjsn@avalon>
X-Original-References <20170511235625.22427-1-eric@anholt.net> <87shk4iqr7.fsf@eliezer.anholt.net> <a7494a8a-a87b-213d-707f-33d67da93267@codeaurora.org>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1644648

Show key headers only | View raw


Hi Archit,

On Thursday 18 May 2017 13:56:19 Archit Taneja wrote:
> On 05/17/2017 12:16 AM, Eric Anholt wrote:

[snip]

> > In terms of physical connections:
> >    [15-pin "DSI" connector on 2835]
> >    
> >     | I2C               | DSI
> >    
> >    / \        SPI       |
> > 
> > [TS]  [Atmel]------[TC358762]
> > 
> >        \                |
> >        
> >         \PWM            |
> >         
> >          \              | DPI
> > 
> > [some backlight]------[some unknown panel]
> > 
> > The binding I'm trying to create is to expose what's necessary for a
> > driver that talks I2C to the Atmel, which then controls the PWM and does
> > the command sequence over SPI to the Toshiba that sets up its end of the
> > DSI link.
> 
> The bridge (Atmel + TC358762 combination) here looks like it's primarily
> an i2c device (i.e, the control bus is i2c). Therefore, the drm-bridge
> driver here should be an i2c driver instead of a mipi_dsi_driver.

Glad to see we agree, that's what I've proposed in a separate answer :-) I'd 
go one step further though, there should be no DRM bridge, just a DRM panel.

> We have the facility to create a mipi DSI device without the need to have
> a corresponding node in DT. The ADV7533 and TC358767 drivers are examples
> of that.
> 
> The following is what the binding could look like, it's same as what Rob
> also mentioned previously in the thread.
> 
> Thanks,
> Archit
> 
> dsi1: dsi@7e700000 {
> 	#address-cells = <1>;
> 	#size-cells = <0>;
> 	<...>
> 
> 	/* The SoC's DSI input/output port */
> 	ports {
> 		#address-cells = <1>;
> 		#size-cells = <0>;
> 
> 		/* port@0 if needed */
> 
> 		port@1 {
> 			dsi_out_port: endpoint {
> 				reg = <1>;
> 				remote-endpoint = <&bridge_dsi_port>;
> 			};
> 		};
> 	};
> };
> 
> i2c_dsi: i2c {
> 	compatible = "i2c-gpio";
> 	#address-cells = <1>;
> 	#size-cells = <0>;
> 	gpios = <&gpio 28 0
> 		 &gpio 29 0>;
> 
> 	/* the Atmel + TC35872 bridge */
> 	pitouchscreen_bridge: bridge@45 {

This should thus be lcd@45.

> 		compatible = "raspberrypi,touchscreen-bridge";

And this raspberrypi,7inch-touchscreen-panel. Shame we haven't standardized 
the vendor name prefix to rpi :-/

> 		reg = <0x45>;
> 
> 		ports {
> 			#address-cells = <1>;
> 			#size-cells = <0>;
> 
> 			port@0 {
> 				reg = <0>;
> 				bridge_dsi_port: endpoint {

This should be named panel_dsi_port.

> 					remote-endpoint = <&dsi_out_port>;
> 				};
> 			};
> 			port@1 {
> 				reg = <1>;
> 				bridge_dpi_port: endpoint {
> 					remote-endpoint = 
<&pitouchscreen_panel_port>;
> 				};
> 			};

The second port is thus not needed.

> 		};

So we can simplify this to

		port {
			panel_dsi_port: endpoint {
				remote-endpoint = <&dsi_out_port>;
			};
		};

(no need for a ports node when there's a single port)

> 	};
> };
> 
> lcd {
> 	compatible = "raspberrypi,7inch-touchscreen-panel";
> 	ports {
> 		#address-cells = <1>;
> 		#size-cells = <0>;
> 		port@0 {
> 			reg = <0>;
> 			pitouchscreen_panel_port: endpoint {
> 				remote-endpoint = <&bridge_dpi_port>;
> 			};
> 		};
> 	};
> };

And this node can go away.

-- 
Regards,

Laurent Pinchart

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Eric Anholt <eric@anholt.net> - 2017-05-12 02:00 +0200
  Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen  nodes. Rob Herring <robh@kernel.org> - 2017-05-15 22:50 +0200
    Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2017-05-16 00:00 +0200
  Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2017-05-16 00:00 +0200
    Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Eric Anholt <eric@anholt.net> - 2017-05-16 02:10 +0200
      Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Rob Herring <robh+dt@kernel.org> - 2017-05-16 02:20 +0200
        Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Eric Anholt <eric@anholt.net> - 2017-05-16 18:50 +0200
          Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2017-05-16 19:00 +0200
            Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Eric Anholt <eric@anholt.net> - 2017-05-16 20:50 +0200
              Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen  nodes. Archit Taneja <architt@codeaurora.org> - 2017-05-18 10:30 +0200
                Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2017-05-18 17:00 +0200
                Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen  nodes. Archit Taneja <architt@codeaurora.org> - 2017-05-19 11:00 +0200
                Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2017-05-19 11:40 +0200
                Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Eric Anholt <eric@anholt.net> - 2017-05-22 23:00 +0200
              Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2017-05-18 16:50 +0200
                Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Eric Anholt <eric@anholt.net> - 2017-05-22 23:00 +0200
      Re: [PATCH 2/4] dt-bindings: Document the Raspberry Pi Touchscreen nodes. Laurent Pinchart <laurent.pinchart@ideasonboard.com> - 2017-05-16 09:30 +0200

csiph-web