Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1644033
| From | Gabriele Paoloni <gabriele.paoloni@huawei.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | RE: [PATCH v2 1/2] PCI/portdrv: add support for different MSI interrupts for PCIe port services |
| Date | 2017-05-18 12:10 +0200 |
| Message-ID | <tIqxz-Ng-1@gated-at.bofh.it> (permalink) |
| References | <tIpBv-8eh-7@gated-at.bofh.it> <tIpBw-8eh-23@gated-at.bofh.it> <tIpUR-8mm-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Christoph > -----Original Message----- > From: linux-pci-owner@vger.kernel.org [mailto:linux-pci- > owner@vger.kernel.org] On Behalf Of Christoph Hellwig > Sent: 18 May 2017 10:27 > To: Gabriele Paoloni > Cc: bhelgaas@google.com; helgaas@kernel.org; Linuxarm; linux- > pci@vger.kernel.org; lukas@wunner.de; linux-kernel@vger.kernel.org; > mika.westerberg@linux.intel.com; hch@infradead.org; liudongdong (C) > Subject: Re: [PATCH v2 1/2] PCI/portdrv: add support for different MSI > interrupts for PCIe port services > > > - * pcie_port_enable_msix - try to set up MSI-X as interrupt mode for > given port > > + * pcie_port_enable_msix_or_msi - try to set up MSI-X or MSI as > interrupt mode > > + * for given port > > just rename it to pcie_port_enable_vecs to avoid the overly long line.. The function is actually renamed but I missed to update the comment, my bad. > > > + * pci_irq_vector() below is able to handle entry > differently > > + * depending on MSI vs MSI-x case > > As mentioned in the review for the other patch: no need to repeat > this for every user of pci_irq_vector. I also missed to remove this comment > > Otherwise this looks fine to me: > > Reviewed-by: Christoph Hellwig <hch@lst.de> Many thanks I'll fix comments and send out v3 straight Cheers Gab
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v2 0/2] add MSI support for PCIe port services and DPC IRQ support Gabriele Paoloni <gabriele.paoloni@huawei.com> - 2017-05-18 11:10 +0200
[PATCH v2 1/2] PCI/portdrv: add support for different MSI interrupts for PCIe port services Gabriele Paoloni <gabriele.paoloni@huawei.com> - 2017-05-18 11:10 +0200
Re: [PATCH v2 1/2] PCI/portdrv: add support for different MSI interrupts for PCIe port services Christoph Hellwig <hch@infradead.org> - 2017-05-18 11:30 +0200
RE: [PATCH v2 1/2] PCI/portdrv: add support for different MSI interrupts for PCIe port services Gabriele Paoloni <gabriele.paoloni@huawei.com> - 2017-05-18 12:10 +0200
csiph-web