Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1637296

Re: [RFC v5 8/9] sched/deadline: base GRUB reclaiming on the inactive utilization

From Peter Zijlstra <peterz@infradead.org>
Newsgroups linux.kernel
Subject Re: [RFC v5 8/9] sched/deadline: base GRUB reclaiming on the inactive utilization
Date 2017-05-08 10:20 +0200
Message-ID <tEM3E-1q2-21@gated-at.bofh.it> (permalink)
References <toh3P-72e-5@gated-at.bofh.it> <toh3P-72e-13@gated-at.bofh.it> <tpDOF-Ur-3@gated-at.bofh.it> <tELAC-10e-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, May 08, 2017 at 09:41:08AM +0200, Luca Abeni wrote:
> Hi Peter,
> 
> sorry for the delay; anyway, I am working on fixing the patchset
> according to the comments I received....
> 
> When working on one of your comments, I have a doubt:
> 
> On Mon, 27 Mar 2017 16:26:33 +0200
> Peter Zijlstra <peterz@infradead.org> wrote:
> [...]
> > 
> > 
> > #define BW_SHIFT	20
> > #define BW_UNIT		(1 << BW_SHIFT)
> > 
> > static inline
> > u64 grub_reclaim(u64 delta, struct rq *rq, struct sched_dl_entity
> > *dl_se) {
> > u64 u_inact = rq->dl.this_bw - rq->dl.running_bw; /* Utot -
> > Uact */ u64 u_act;
> [...]
> 
> I think introducing the BW_SHIFT and BW_UNIT defines can be more useful
> in a previous patch (patch 4, where I introduce the "grub_reclaim()"
> function, and use ">> 20" for the first time.

Sure..

> Moreover, the "20" magic number is already used in core.c... Should I
> introduce the defines in sched/sched.h, and change the existing core.c
> code too?

Yes please.

> Is it ok to embed this change in patch 4 (sched/deadline:
> implement GRUB accounting), or should it go in a separate patch?

Whatever you feel is nicest. Currently the thing is fully contained in
the one to_ratio() function (afaict), so the first patch where you make
it escape would be fine.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [RFC v5 8/9] sched/deadline: base GRUB reclaiming on the  inactive utilization Luca Abeni <luca.abeni@santannapisa.it> - 2017-05-08 09:50 +0200
  Re: [RFC v5 8/9] sched/deadline: base GRUB reclaiming on the  inactive utilization Peter Zijlstra <peterz@infradead.org> - 2017-05-08 10:20 +0200
    Re: [RFC v5 8/9] sched/deadline: base GRUB reclaiming on the  inactive utilization Luca Abeni <luca.abeni@santannapisa.it> - 2017-05-09 11:40 +0200

csiph-web