Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1633592

Re: [PATCH 1/2] spi: imx: dynamic burst length adjust for PIO mode

From Jiada Wang <jiada_wang@mentor.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] spi: imx: dynamic burst length adjust for PIO mode
Date 2017-05-01 12:20 +0200
Message-ID <tCgAV-7Pm-1@gated-at.bofh.it> (permalink)
References <t8tVn-5al-5@gated-at.bofh.it> <t8tVn-5al-3@gated-at.bofh.it> <taQ1s-5hv-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hello Mark

Sorry, somehow I missed your following comment

On 02/14/2017 10:20 AM, Mark Brown wrote:
> On Wed, Feb 08, 2017 at 03:20:27PM +0900, Jiada Wang wrote:
>
> This looks basically fine, a couple of fairly minor things here:
>
>> +	for (i = 0; i<  transfer->len / 4; i++) {
>> +		u8 temp;
>> +
>> +		temp = *(buf + i * 4);
>> +		*(buf + i * 4) = *(buf + i * 4 + 3);
>> +		*(buf + i * 4 + 3) = temp;
> Should this be using one of the cpu_to_ functions?  It's a bit unclear
> what the goal is here and if it'll work if the kernel is big endian
> (which people do do with i.MX systems IIRC).
indeed, with big endian kernel, this function won't work
I will replace the algo here with cpu_to_* in next version

Thanks,
Jiada

>> +	if (spi_imx->bpw_w == 1)
>> +		spi_imx_buf_rx_u8(spi_imx);
>> +	else if (spi_imx->bpw_w == 2)
>> +		spi_imx_buf_rx_u16(spi_imx);
> switch statement please.
>
>> +	if (spi_imx->dynamic_burst) {
>> +		spi_imx->count_index =
>> +				spi_imx->count>  MX51_ECSPI_CTRL_MAX_BURST ?
>> +				spi_imx->count % MX51_ECSPI_CTRL_MAX_BURST :
>> +				spi_imx->count % sizeof(u32);
> Just write a normal if statement please, it's easier to read.

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH 1/2] spi: imx: dynamic burst length adjust for PIO mode Jiada Wang <jiada_wang@mentor.com> - 2017-05-01 12:20 +0200

csiph-web