Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1634399

Re: [PATCH 2/3] x86/numa_emulation: assign physnode_mask directly from numa_nodes_parsed

From Wei Yang <richard.weiyang@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/3] x86/numa_emulation: assign physnode_mask directly from numa_nodes_parsed
Date 2017-05-02 15:10 +0200
Message-ID <tCFJ0-77a-37@gated-at.bofh.it> (permalink)
References <tuKPw-3hW-19@gated-at.bofh.it> <tuKPy-3hW-77@gated-at.bofh.it> <tuRQZ-850-1@gated-at.bofh.it> <tuT6q-mh-7@gated-at.bofh.it> <tCrd1-5UI-59@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

On Mon, May 01, 2017 at 02:37:06PM -0700, David Rientjes wrote:
>On Tue, 11 Apr 2017, Wei Yang wrote:
>
>> On Mon, Apr 10, 2017 at 05:26:03PM -0700, David Rientjes wrote:
>> >On Tue, 11 Apr 2017, Wei Yang wrote:
>> >
>> >> According to current code path, numa_nodes_parsed is already setup when
>> >> numa_emucation() is called.
>> >> 
>> >>     x86_numa_init()
>> >>         numa_init()
>> >> 	    init_func()
>> >> 
>> >> 	    numa_emulation()
>> >> 
>> >>             numa_register_memblks()
>> >>
>> >
>> >s/numa_emucation/numa_emulation/, but I think everything above should just 
>> >be reworded to say the following since it establishes the dependency:
>> >
>> >numa_init() has already called init_func(), which is responsible for 
>> >setting numa_nodes_parsed, so use this nodemask instead of re-finding it 
>> >when calling numa_emulation().
>> >
>> 
>> Yep, thanks.
>> 
>> Looks your change log is better :-)
>> 
>
>Thanks!  Would it be possible to refresh the series and repost for the x86 
>maintainers?

Sure, I have sent out V2 with changes from your comments.

Thanks~

-- 
Wei Yang
Help you, Help me

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH 2/3] x86/numa_emulation: assign physnode_mask directly  from numa_nodes_parsed David Rientjes <rientjes@google.com> - 2017-05-01 23:40 +0200
  Re: [PATCH 2/3] x86/numa_emulation: assign physnode_mask directly  from numa_nodes_parsed Wei Yang <richard.weiyang@gmail.com> - 2017-05-02 15:10 +0200

csiph-web