Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1633468
| Path | csiph.com!3.us.feeder.erje.net!2.us.feeder.erje.net!feeder.erje.net!2.eu.feeder.erje.net!news.unit0.net!news.panservice.it!bofh.it!news.nic.it!robomod |
|---|---|
| From | Михайлов Алексей Анатольевич <minimumlaw@rambler.ru> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge |
| Date | Sun, 30 Apr 2017 19:40:01 +0200 |
| Message-ID | <tC0Zb-65x-5@gated-at.bofh.it> (permalink) |
| References | <tBBHr-7p2-7@gated-at.bofh.it> <tBBHr-7p2-9@gated-at.bofh.it> <tBDJf-c0-11@gated-at.bofh.it> |
| X-Original-To | Sebastian Reichel <sre@kernel.org> |
| Dkim-Signature | v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=rambler.ru; s=mail; h=Content-Transfer-Encoding:Content-Type:In-Reply-To:MIME-Version:Date:Message-ID:From:References:Cc:To:Subject; bh=doS5fiXYm6GaHh6T1ArGL/8ZZ/hNqdL4siCX2WJXgig=; b=V5IHG/9kF9lZ9+iw9m94rhxdtz5zPR5jXwDGSu3eJahzAP+j2i4vUo9yv+CJ3TLOlr/ndC8T/qU0DJN2nN1eJ86N28Jst0SHw8TPuni/ihnzMdThhZs9hSFIvE/0LL/M+PpGX8CnqZoFsOnnZ77qvsgozkm6A5JD4mWPYwcTZ14=; |
| User-Agent | Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Thunderbird/52.0.1 |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset=windows-1252; format=flowed |
| Content-Transfer-Encoding | 7bit |
| Content-Language | en-GB |
| X-Rambler-User | minimumlaw@rambler.ru/178.70.116.135 |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 32 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | linux-kernel@vger.kernel.org, linux-pm@vger.kernel.org, zbr@ioremap.net |
| X-Original-Date | Sun, 30 Apr 2017 20:32:10 +0300 |
| X-Original-Message-ID | <77d557e3-3ff3-de60-826c-b98937360d8c@rambler.ru> |
| X-Original-References | <20170429143429.5685-1-minimumlaw@rambler.ru> <20170429143429.5685-3-minimumlaw@rambler.ru> <20170429164053.olynja4kyqpwhfpk@earth> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1633468 |
Show key headers only | View raw
Hi!
>> [...]
>>
>> + * FixMe:
>> + * Device without no_thermal = true not register (err -22)
>> + * Len of platform device name "max17211-battery.X.auto"
>> + * more than 20 chars limit in THERMAL_NAME_LENGTH from
>> + * include/uapi/linux/thermal.h
>> + */
> IIRC we already had problems with small THERMAL_NAME_LENGTH before.
> I suggest to add another patch, that increases THERMAL_NAME_LENGTH
> (don't forget to Cc/To the thermal subsystem people).
May be rename "max17211-battery" to "max17211" and remove no_thermal =
true? This case thermal zone will work again. In current (mainline)
kernel all drivers "xxxxxx-battery" (like ds2780-battery or
ds2760-battery) compiled, but not working (not registered). They can
start working again without thermal zone by adding no_thermal = true or
by remove "-battery" from platform device name. Alternative limit on
THERMAL_NAME_LENGTH may be extended.
>> + info->bat = power_supply_register(&pdev->dev, &info->bat_desc,
>> + &psy_cfg);
>> + if (IS_ERR(info->bat)) {
>> + dev_err(info->dev, "failed to register battery\n");
>> + return PTR_ERR(info->bat);
>> + }
> Please use devm_power_supply_register() and drop the remove
> function.
Khm... probe/remove paired functions. I can use
devm_power_supply_register in my code. But all other fuel gauge drivers
use classic probe/remove pair. Which decision will be more correct?
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge "Alex A. Mihaylov" <minimumlaw@rambler.ru> - 2017-04-29 16:40 +0200
Re: [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge Sebastian Reichel <sre@kernel.org> - 2017-04-29 18:50 +0200
Re: [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge Михайлов Алексей Анатольевич <minimumlaw@rambler.ru> - 2017-04-30 19:40 +0200
Re: [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge Sebastian Reichel <sre@kernel.org> - 2017-04-30 22:50 +0200
csiph-web