Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1631895
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH] x86, uaccess, pmem: introduce copy_from_iter_writethru for dax + pmem |
| Date | 2017-04-27 08:40 +0200 |
| Message-ID | <tALfQ-5aa-15@gated-at.bofh.it> (permalink) |
| References | <tADii-8v0-5@gated-at.bofh.it> <tADih-8v0-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
* Dan Williams <dan.j.williams@intel.com> wrote: > +#ifdef CONFIG_ARCH_HAS_UACCESS_WRITETHRU > +#define __HAVE_ARCH_MEMCPY_WRITETHRU 1 > +void memcpy_writethru(void *dst, const void *src, size_t cnt); > +#endif This should be named memcpy_wt(), which is the well-known postfix for write-through. We already have ioremap_wt(), set_memory_wt(), etc. - no need to introduce a longer variant with uncommon spelling. Thanks, Ingo
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC PATCH] x86, uaccess, pmem: introduce copy_from_iter_writethru for dax + pmem Dan Williams <dan.j.williams@intel.com> - 2017-04-27 00:10 +0200
Re: [RFC PATCH] x86, uaccess, pmem: introduce copy_from_iter_writethru for dax + pmem Ingo Molnar <mingo@kernel.org> - 2017-04-27 08:40 +0200
[PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Dan Williams <dan.j.williams@intel.com> - 2017-04-28 21:50 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Ingo Molnar <mingo@kernel.org> - 2017-05-05 09:00 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Dan Williams <dan.j.williams@intel.com> - 2017-05-05 16:20 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-05-05 22:40 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Dan Williams <dan.j.williams@intel.com> - 2017-05-06 00:30 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-05-06 00:50 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Dan Williams <dan.j.williams@intel.com> - 2017-05-06 04:20 +0200
RE: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-05-06 05:20 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Ingo Molnar <mingo@kernel.org> - 2017-05-06 11:50 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Dan Williams <dan.j.williams@intel.com> - 2017-05-06 16:00 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Ingo Molnar <mingo@kernel.org> - 2017-05-08 00:30 +0200
RE: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-05-08 05:10 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Ross Zwisler <ross.zwisler@linux.intel.com> - 2017-05-08 22:40 +0200
Re: [PATCH v2] x86, uaccess: introduce copy_from_iter_wt for pmem / writethrough operations Dan Williams <dan.j.williams@intel.com> - 2017-05-08 22:50 +0200
csiph-web