Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1578954

Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions

From Thomas Gleixner <tglx@linutronix.de>
Newsgroups linux.kernel
Subject Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions
Date 2017-02-11 09:30 +0100
Message-ID <t9Be9-6LC-9@gated-at.bofh.it> (permalink)
References <t8XJL-7cN-11@gated-at.bofh.it> <t8XJL-7cN-13@gated-at.bofh.it> <t8XJL-7cN-9@gated-at.bofh.it> <t9pPH-8bb-9@gated-at.bofh.it> <t9qVr-nT-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, 11 Feb 2017, Dmitry Safonov wrote:

> 2017-02-10 23:10 GMT+03:00 Thomas Gleixner <tglx@linutronix.de>:
> > On Thu, 9 Feb 2017, Borislav Petkov wrote:
> >> I can't say that I'm thrilled about the ifdeffery this is adding.
> >>
> >> But I can't think of a cleaner approach at a quick glance, though -
> >> that's generic and arch-specific code intertwined muck. Sad face.
> >
> > It's trivial enough to do ....
> >
> > Thanks,
> >
> >         tglx
> >
> > ---
> >  arch/x86/mm/mmap.c |   22 ++++++++++------------
> >  1 file changed, 10 insertions(+), 12 deletions(-)
> >
> > --- a/arch/x86/mm/mmap.c
> > +++ b/arch/x86/mm/mmap.c
> > @@ -55,6 +55,10 @@ static unsigned long stack_maxrandom_siz
> >  #define MIN_GAP (128*1024*1024UL + stack_maxrandom_size())
> >  #define MAX_GAP (TASK_SIZE/6*5)
> >
> > +#ifndef CONFIG_COMPAT
> > +# define mmap_rnd_compat_bits  mmap_rnd_bits
> > +#endif
> > +
> 
> >From my POV, I can't say that it's clearer to shadow mmap_compat_bits
> like that then to have two functions with native/compat names.
> But if you insist, I'll resend patches set with your version.

You can make that

#ifdef CONFIG_64BIT
# define mmap32_rnd_bits  mmap_compat_rnd_bits
# define mmap64_rnd_bits  mmap_rnd_bits
#else
# define mmap32_rnd_bits  mmap_rnd_bits
# define mmap64_rnd_bits  mmap_rnd_bits
#endif

and use that. That's still way more readable than the unholy ifdef mess.

Thanks,

	tglx

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native  versions Borislav Petkov <bp@alien8.de> - 2017-02-09 15:20 +0100
  Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions Andy Lutomirski <luto@amacapital.net> - 2017-02-10 00:10 +0100
  Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native  versions Thomas Gleixner <tglx@linutronix.de> - 2017-02-10 21:20 +0100
    Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native  versions Borislav Petkov <bp@suse.de> - 2017-02-10 21:30 +0100
    Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions Dmitry Safonov <0x7f454c46@gmail.com> - 2017-02-10 22:30 +0100
      Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native  versions Thomas Gleixner <tglx@linutronix.de> - 2017-02-11 09:30 +0100
        Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native  versions Thomas Gleixner <tglx@linutronix.de> - 2017-02-13 12:30 +0100

csiph-web