Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1575988

[PATCH 01/18] HID: Use kmalloc_array() in hid_input_field()

From SF Markus Elfring <elfring@users.sourceforge.net>
Newsgroups linux.kernel
Subject [PATCH 01/18] HID: Use kmalloc_array() in hid_input_field()
Date 2017-02-07 20:50 +0100
Message-ID <t8jW2-74w-31@gated-at.bofh.it> (permalink)
References <t8jMm-70G-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Markus Elfring <elfring@users.sourceforge.net>
Date: Mon, 6 Feb 2017 18:18:41 +0100

A multiplication for the size determination of a memory allocation
indicated that an array data structure should be processed.
Thus use the corresponding function "kmalloc_array".

This issue was detected by using the Coccinelle software.

Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
 drivers/hid/hid-core.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
index 538ff697a4cf..9b0a97bbde96 100644
--- a/drivers/hid/hid-core.c
+++ b/drivers/hid/hid-core.c
@@ -1272,7 +1272,7 @@ static void hid_input_field(struct hid_device *hid, struct hid_field *field,
 	__s32 max = field->logical_maximum;
 	__s32 *value;
 
-	value = kmalloc(sizeof(__s32) * count, GFP_ATOMIC);
+	value = kmalloc_array(count, sizeof(__s32), GFP_ATOMIC);
 	if (!value)
 		return;
 
-- 
2.11.1

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/18] HID: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:40 +0100
  [PATCH 06/18] HID: Improve another size determination in  hid_scan_report() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:50 +0100
  [PATCH 07/18] HID: Improve another size determination in  hid_register_report() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:50 +0100
  [PATCH 04/18] HID: Improve another size determination in  open_collection() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:50 +0100
  [PATCH 03/18] HID: Use kmalloc_array() in open_collection() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:50 +0100
  [PATCH 05/18] HID: Improve two size determinations in  hid_open_report() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:50 +0100
  [PATCH 01/18] HID: Use kmalloc_array() in hid_input_field() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:50 +0100
  [PATCH 02/18] HID: Delete an error message for a failed memory  allocation in open_collection() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 20:50 +0100
  [PATCH 09/18] HID: Return an error code only as a constant in  hid_allocate_device() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:00 +0100
  [PATCH 08/18] HID: Adjust five checks for null pointers SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:00 +0100
  [PATCH 11/18] HID-debug: Delete an unnecessary seq_printf() call in  hid_dump_device() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:00 +0100
  [PATCH 12/18] HID-debug: Replace 12 seq_printf() calls by seq_puts() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:00 +0100
  [PATCH 10/18] HID-debug: Replace five seq_printf() calls by  seq_putc() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:00 +0100
  [PATCH 16/18] HID-debug: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:10 +0100
  [PATCH 18/18] HID-picoLCD: Use seq_puts() in  picolcd_debug_reset_show() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:10 +0100
  [PATCH 15/18] HID-debug: Return an error code only as a constant in  hid_debug_events_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:10 +0100
  [PATCH 13/18] HID-debug: Combine 11 seq_printf() calls into one call  in hid_dump_field() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:10 +0100
    Re: [PATCH 13/18] HID-debug: Combine 11 seq_printf() calls into one  call in hid_dump_field() Joe Perches <joe@perches.com> - 2017-02-08 00:00 +0100
  [PATCH 14/18] HID-debug: Adjust two function calls together with a  variable assignment SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:10 +0100
  [PATCH 17/18] HID-debug: Delete an unnecessary variable  initialisation in hid_resolv_usage() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-02-07 21:10 +0100

csiph-web