Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1575433

Re: [PATCH 18/89] sched/core: Move task->mm handling methods to <linux/sched/mm.h>

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH 18/89] sched/core: Move task->mm handling methods to <linux/sched/mm.h>
Date 2017-02-07 08:40 +0100
Message-ID <t88xB-8hL-9@gated-at.bofh.it> (permalink)
References <t7RGp-5x6-3@gated-at.bofh.it> <t7RGq-5x6-15@gated-at.bofh.it> <t7SsO-64V-11@gated-at.bofh.it> <t80gG-2FR-19@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Ingo Molnar <mingo@kernel.org> wrote:

> 
> * Christoph Hellwig <hch@infradead.org> wrote:
> 
> > On Mon, Feb 06, 2017 at 02:28:21PM +0100, Ingo Molnar wrote:
> > > Move the following task->mm helper APIs into a new header file,
> > > <linux/sched/mm.h>, to further reduce the size and complexity
> > > of <linux/sched.h>:
> > 
> > Is there any good reason why they can't just go into linux/mm.h?
> 
> So mm.h is pretty large already, and I wanted to preserve the natural API and 
> header separation that was the result of these APIs being in sched.h. Many 
> smaller headers are so much easier to maintain, and they are much more readable 
> as well in my experience.

The other big reason is that putting these APIs (mmget()/mmput()/etc.) into mm.h 
would cause mm.h to include sched.h, which would make the whole major kernel 
header coupling situation I'm trying to improve with this series so much worse all 
around.

The current stats are: <linux/mm.h> is included in almost as many files as 
<linux/sched.h>, and about half of them don't include <linux/sched.h>. So adding 
these APIs would significantly bloat the kernel in the header build space. So we 
really don't want to include sched.h in mm.h.

Thanks,

	Ingo

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH 18/89] sched/core: Move task->mm handling methods to <linux/sched/mm.h> Ingo Molnar <mingo@kernel.org> - 2017-02-06 14:40 +0100
  Re: [PATCH 18/89] sched/core: Move task->mm handling methods to  <linux/sched/mm.h> Christoph Hellwig <hch@infradead.org> - 2017-02-06 15:30 +0100
    Re: [PATCH 18/89] sched/core: Move task->mm handling methods to  <linux/sched/mm.h> Ingo Molnar <mingo@kernel.org> - 2017-02-06 23:50 +0100
      Re: [PATCH 18/89] sched/core: Move task->mm handling methods to  <linux/sched/mm.h> Ingo Molnar <mingo@kernel.org> - 2017-02-07 08:40 +0100

csiph-web