Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1573426
| From | Yasuaki Ishimatsu <yasu.isimatu@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [Resend PATCH 2/2] mm/memory_hotplug: set magic number to page->freelsit instead of page->lru.next |
| Date | 2017-02-03 21:40 +0100 |
| Message-ID | <t6SOd-6J7-9@gated-at.bofh.it> (permalink) |
| References | <sQRjs-5gE-19@gated-at.bofh.it> <sQRjs-5gE-17@gated-at.bofh.it> <sQRt8-5jR-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Andrew,
Please apply the following patch into your tree because patch
("mm/memory_hotplug: set magic number to page->freelsit instead of page->lru.next")
is not applied correctly.
---
From: Yasuaki Ishimatsu <isimatu.yasuaki@jp.fujitsu.com>
Date: Fri, 3 Feb 2017 15:18:03 -0500
Subject: [PATCH] Remove unnecessary code from get_page_bootmem()
The following patch is not applied correctly.
http://lkml.kernel.org/r/2c29bd9f-5b67-02d0-18a3-8828e78bbb6f@gmail.com
So the following unnecessary code still remains.
get_page_bootmem()
{
...
page->lru.next = (struct list_head *)type;
...
The patch removes this code from get_page_bootmem()
Signed-off-by: Yasuaki Ishimatsu <isimatu.yasuaki@jp.fujitsu.com>
---
mm/memory_hotplug.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c
index 19b460a..50b586c 100644
--- a/mm/memory_hotplug.c
+++ b/mm/memory_hotplug.c
@@ -179,7 +179,6 @@ static void release_memory_resource(struct resource *res)
void get_page_bootmem(unsigned long info, struct page *page,
unsigned long type)
{
- page->lru.next = (struct list_head *)type;
page->freelist = (void *)type;
SetPagePrivate(page);
set_page_private(page, info);
--
1.8.3.1
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [Resend PATCH 2/2] mm/memory_hotplug: set magic number to page->freelsit instead of page->lru.next Yasuaki Ishimatsu <yasu.isimatu@gmail.com> - 2017-02-03 21:40 +0100 Re: [Resend PATCH 2/2] mm/memory_hotplug: set magic number to page->freelsit instead of page->lru.next Yasuaki Ishimatsu <yasu.isimatu@gmail.com> - 2017-02-03 22:20 +0100
csiph-web