Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1570369

Re: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and px regulator resource.

From Bjorn Andersson <bjorn.andersson@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and px regulator resource.
Date 2017-01-31 06:50 +0100
Message-ID <t5zuk-5gO-69@gated-at.bofh.it> (permalink)
References <t5lKF-5uN-15@gated-at.bofh.it> <t5lKG-5uN-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon 30 Jan 07:03 PST 2017, Avaneesh Kumar Dwivedi wrote:

> This patch add additional clock and regulator resource which are
> initialized based on compatible and has no impact on existing driver
> working. This resourse addition enable the existing driver to handle.
> low pass sensor processor device also.
> 
> Signed-off-by: Avaneesh Kumar Dwivedi <akdwived@codeaurora.org>

Applied, with below modification.

> ---
>  drivers/remoteproc/qcom_adsp_pil.c | 43 +++++++++++++++++++++++++++++++-------
>  1 file changed, 36 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/remoteproc/qcom_adsp_pil.c b/drivers/remoteproc/qcom_adsp_pil.c
[..]
>  static int adsp_init_regulator(struct qcom_adsp *adsp)
>  {
> -	adsp->cx_supply = devm_regulator_get(adsp->dev, "cx");
> +	adsp->cx_supply = devm_regulator_get(adsp->dev, "vdd_cx");

We should not change the name of devicetree properties, so I dropped
"vdd_" on both of these.

>  	if (IS_ERR(adsp->cx_supply))
>  		return PTR_ERR(adsp->cx_supply);
>  
>  	regulator_set_load(adsp->cx_supply, 100000);
>  
> +	adsp->px_supply = devm_regulator_get(adsp->dev, "vdd_px");
> +	if (IS_ERR(adsp->px_supply))
> +		return PTR_ERR(adsp->px_supply);

Regards,
Bjorn

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and px regulator resource. Avaneesh Kumar Dwivedi <akdwived@codeaurora.org> - 2017-01-30 16:10 +0100
  Re: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and  px regulator resource. Bjorn Andersson <bjorn.andersson@linaro.org> - 2017-01-31 06:50 +0100
    Re: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and  px regulator resource. Bjorn Andersson <bjorn.andersson@linaro.org> - 2017-01-31 07:10 +0100
    Re: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and px  regulator resource. "Dwivedi, Avaneesh Kumar (avani)" <akdwived@codeaurora.org> - 2017-01-31 07:10 +0100

csiph-web