Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1571250
| From | Dmitry Torokhov <dmitry.torokhov@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/2] powerpc: make use of for_each_node_by_name() instead of open-coding it |
| Date | 2017-02-01 03:30 +0100 |
| Message-ID | <t5SQh-8rf-3@gated-at.bofh.it> (permalink) |
| References | <t5Sng-82R-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jan 31, 2017 at 05:54:37PM -0800, Dmitry Torokhov wrote: > Instead of manually coding the loop with of_find_node_by_name(), let's > switch to the standard macro for iterating over nodes with given name. > > Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com> > --- > arch/powerpc/platforms/83xx/mpc832x_mds.c | 2 +- > arch/powerpc/platforms/83xx/mpc832x_rdb.c | 2 +- > arch/powerpc/platforms/83xx/mpc836x_mds.c | 2 +- > arch/powerpc/platforms/cell/interrupt.c | 3 +-- > arch/powerpc/platforms/cell/setup.c | 3 +-- > arch/powerpc/platforms/cell/spider-pic.c | 3 +-- > arch/powerpc/platforms/powermac/feature.c | 2 +- > 7 files changed, 7 insertions(+), 10 deletions(-) > > diff --git a/arch/powerpc/platforms/83xx/mpc832x_mds.c b/arch/powerpc/platforms/83xx/mpc832x_mds.c > index bb7b25acf26f..1e92f806ee60 100644 > --- a/arch/powerpc/platforms/83xx/mpc832x_mds.c > +++ b/arch/powerpc/platforms/83xx/mpc832x_mds.c > @@ -75,7 +75,7 @@ static void __init mpc832x_sys_setup_arch(void) > par_io_init(np); > of_node_put(np); > > - for (np = NULL; (np = of_find_node_by_name(np, "ucc")) != NULL;) > + for_each_node_by_name(np. "ucc") Gah, kbuild robot even told me about this typo and I missed it. Please let me know if you can fix up or if I should resend (or drop). I'd rather it not get dropped as I want to convert of_find_node_by_name() to stop dropping reference to the starting node, as half of the users do not expect it. Thanks. -- Dmitry
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 1/2] powerpc: make use of for_each_node_by_name() instead of open-coding it Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-02-01 03:00 +0100 [PATCH 2/2] powerpc: make use of for_each_node_by_type() instead of open-coding it Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-02-01 03:00 +0100 Re: [PATCH 1/2] powerpc: make use of for_each_node_by_name() instead of open-coding it Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-02-01 03:30 +0100
csiph-web