Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1571077

Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero()

From Fabian Frederick <fabf@skynet.be>
Newsgroups linux.kernel
Subject Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero()
Date 2017-01-31 22:00 +0100
Message-ID <t5NGV-5im-7@gated-at.bofh.it> (permalink)
References <t5pbA-7p2-35@gated-at.bofh.it> <t5EaC-84y-21@gated-at.bofh.it> <t5KJ4-3yR-21@gated-at.bofh.it> <t5M89-4ww-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



> On 31 January 2017 at 20:17 Peter Zijlstra <peterz@infradead.org> wrote:
>
>
> On Tue, Jan 31, 2017 at 06:41:28PM +0100, Fabian Frederick wrote:
> >
> >
> > > On 31 January 2017 at 11:41 Peter Zijlstra <peterz@infradead.org> wrote:
> > >
> > >
> > > On Mon, Jan 30, 2017 at 07:39:38PM +0100, Fabian Frederick wrote:
> > > > complementary definition to atomic_inc_not_zero() featured in
> > > > lib/fault-inject.c
> > >
> > > Why?
> >
> > Maybe this commit message should be ok ?
> >
> > complementary definition to atomic_inc_not_zero() featured in
> > lib/fault-inject.c
> > and is more readable than atomic_add_unless((v), -1, 0) used in different
> > places.
>
> I still don't see why such a primitive makes sense. Yes there's a few
> usage sites, but from them I don't see a sensible pattern.
>
> What sane pattern desires this?

Once again it's just about readability:

"add -1 unless value is zero" looks more complex in code than "dec not zero"
but maybe it's just a matter of taste :) It it's not the case why would there be
more sense about having
atomic_inc_not_zero() globally ?

Regards,
Fabian

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Fabian Frederick <fabf@skynet.be> - 2017-01-30 19:50 +0100
  Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Ingo Molnar <mingo@kernel.org> - 2017-01-31 08:40 +0100
  Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Peter Zijlstra <peterz@infradead.org> - 2017-01-31 11:50 +0100
    Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Fabian Frederick <fabf@skynet.be> - 2017-01-31 18:50 +0100
      Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Peter Zijlstra <peterz@infradead.org> - 2017-01-31 20:20 +0100
        Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Fabian Frederick <fabf@skynet.be> - 2017-01-31 22:00 +0100
          Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Peter Zijlstra <peterz@infradead.org> - 2017-02-01 10:30 +0100
            Re: [PATCH 01/14] locking/atomic: import atomic_dec_not_zero() Fabian Frederick <fabf@skynet.be> - 2017-02-01 20:30 +0100

csiph-web