Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1569291
| From | Lukasz Majewski <lukma@denx.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v5 00/11] pwm: imx: Provide atomic operation for IMX PWM driver |
| Date | 2017-01-29 23:00 +0100 |
| Message-ID | <t55FT-3Wy-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
This patch set brings atomic operation to i.MX's PWMv2 driver.
This work has been supported and suggested by Boris Brezillon [1] and
Stefan Agner, by showing how simple the transition could be :-) (in theory).
It has been divided into several steps:
- Remove ipg clock and enable per clock when required (as proposed by Boris
Brezillon)
- Provide different pwm ops for PWMv1 and PWMv2
- Separate PWMv1 commits from "generic" and non atomic PWM code
NOTE: Since I do _not_ have board with PWMv1, I would like to ask somebody
for testing
- Move some imx_config_v2 code to separate functions
- Provide PWM atomic implementation (the ->apply() driver) for PWMv2 in a
single patch for better readability. This patch also includes some code
to address potential issues on i.MX7 (lack of peripheral clock when accessing
PWM registers).
- Remove redundant PWM code (disable, enable, config callbacks)
- Update proper documentation entries
- Provide support for polarity inversion on top of atomic PWM rework
Test HW:
--------
This patch set has been tested on i.MX6q board with
v4.10-rc5 kernel SHA1: 1b1bc42c1692e9b62756323c675a44cb1a1f9dbd
The PWM operation has been tested with pwm_bl backlight driver by changing
its brightness.
[1]: http://patchwork.ozlabs.org/patch/685402/
Lothar Wassmann (2):
pwm: print error messages with pr_err() instead of pr_debug()
pwm: core: make the PWM_POLARITY flag in DTB optional
Lukasz Majewski (8):
pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2
pwm: imx: Rewrite imx_pwm_*_v1 code to facilitate switch to atomic pwm
operation
pwm: imx: Move PWMv2 software reset code to a separate function
pwm: imx: Move PWMv2 wait for fifo slot code to a separate function
pwm: imx: Provide atomic PWM support for i.MX PWMv2
pwm: imx: Remove redundant i.MX PWMv2 code
pwm: imx: doc: Update imx-pwm.txt documentation entry
pwm: imx: Add polarity inversion support to i.MX's PWMv2
Sascha Hauer (1):
pwm: imx: remove ipg clock and enable per clock when required
Documentation/devicetree/bindings/pwm/imx-pwm.txt | 6 +-
drivers/pwm/core.c | 26 ++-
drivers/pwm/pwm-imx.c | 269 ++++++++++------------
3 files changed, 145 insertions(+), 156 deletions(-)
--
2.1.4
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v5 00/11] pwm: imx: Provide atomic operation for IMX PWM driver Lukasz Majewski <lukma@denx.de> - 2017-01-29 23:00 +0100
[PATCH v5 05/11] pwm: imx: Move PWMv2 software reset code to a separate function Lukasz Majewski <lukma@denx.de> - 2017-01-29 23:00 +0100
Re: [PATCH v5 05/11] pwm: imx: Move PWMv2 software reset code to a separate function Thierry Reding <thierry.reding@gmail.com> - 2017-01-30 08:30 +0100
[PATCH v5 02/11] pwm: imx: remove ipg clock and enable per clock when required Lukasz Majewski <lukma@denx.de> - 2017-01-29 23:00 +0100
[PATCH v5 11/11] pwm: imx: Add polarity inversion support to i.MX's PWMv2 Lukasz Majewski <lukma@denx.de> - 2017-01-29 23:00 +0100
[PATCH v5 10/11] pwm: imx: doc: Update imx-pwm.txt documentation entry Lukasz Majewski <lukma@denx.de> - 2017-01-29 23:00 +0100
[PATCH v5 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Lukasz Majewski <lukma@denx.de> - 2017-01-29 23:00 +0100
Re: [PATCH v5 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Thierry Reding <thierry.reding@gmail.com> - 2017-01-30 08:30 +0100
Re: [PATCH v5 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Thierry Reding <thierry.reding@gmail.com> - 2017-01-30 08:50 +0100
Re: [PATCH v5 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Lukasz Majewski <lukma@denx.de> - 2017-01-30 09:40 +0100
Re: [PATCH v5 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Thierry Reding <thierry.reding@gmail.com> - 2017-01-30 10:00 +0100
Re: [PATCH v5 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Lukasz Majewski <lukma@denx.de> - 2017-01-30 10:00 +0100
Re: [PATCH v5 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Thierry Reding <thierry.reding@gmail.com> - 2017-01-30 10:10 +0100
csiph-web