Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1569084
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 09/50] x86/boot/e820: Remove unnecessary __ASSEMBLY__ guard |
| Date | 2017-01-29 01:10 +0100 |
| Message-ID | <t4Leb-8ik-23@gated-at.bofh.it> (permalink) |
| References | <t4JvH-7bG-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
asm/e820/api.h had a spurious __ASSEMBLY__ guard - but the API header is not included in any assembly files. Remove it. No change in functionality. Cc: Alex Thorlton <athorlton@sgi.com> Cc: Andy Lutomirski <luto@kernel.org> Cc: Borislav Petkov <bp@alien8.de> Cc: Brian Gerst <brgerst@gmail.com> Cc: Dan Williams <dan.j.williams@intel.com> Cc: Denys Vlasenko <dvlasenk@redhat.com> Cc: H. Peter Anvin <hpa@zytor.com> Cc: Huang, Ying <ying.huang@intel.com> Cc: Josh Poimboeuf <jpoimboe@redhat.com> Cc: Juergen Gross <jgross@suse.com> Cc: Linus Torvalds <torvalds@linux-foundation.org> Cc: Paul Jackson <pj@sgi.com> Cc: Peter Zijlstra <peterz@infradead.org> Cc: Rafael J. Wysocki <rjw@sisk.pl> Cc: Tejun Heo <tj@kernel.org> Cc: Thomas Gleixner <tglx@linutronix.de> Cc: Wei Yang <richard.weiyang@gmail.com> Cc: Yinghai Lu <yinghai@kernel.org> Cc: linux-kernel@vger.kernel.org Signed-off-by: Ingo Molnar <mingo@kernel.org> --- arch/x86/include/asm/e820/api.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/arch/x86/include/asm/e820/api.h b/arch/x86/include/asm/e820/api.h index 88a19257abb9..b45550b662a9 100644 --- a/arch/x86/include/asm/e820/api.h +++ b/arch/x86/include/asm/e820/api.h @@ -3,7 +3,6 @@ #include <asm/e820/types.h> -#ifndef __ASSEMBLY__ /* see comment in arch/x86/kernel/e820.c */ extern struct e820map *e820; extern struct e820map *e820_saved; @@ -47,7 +46,6 @@ static inline bool is_ISA_range(u64 start, u64 end) return start >= ISA_START_ADDRESS && end <= ISA_END_ADDRESS; } -#endif /* __ASSEMBLY__ */ #include <linux/ioport.h> #define HIGH_MEMORY (1024*1024) -- 2.7.4
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/50] x86: Clean up and reorganize the E820 table handling code Ingo Molnar <mingo@kernel.org> - 2017-01-29 00:30 +0100 [PATCH 03/50] x86/boot/e820: Move asm/e820.h to asm/e820/api.h Ingo Molnar <mingo@kernel.org> - 2017-01-29 00:30 +0100 [PATCH 21/50] x86/boot/e820: Consolidate 'struct e820_entry *entry' local variable names Ingo Molnar <mingo@kernel.org> - 2017-01-29 00:30 +0100 [PATCH 17/50] x86/boot/e820: Rename default_machine_specific_memory_setup() to e820__memory_setup_default() Ingo Molnar <mingo@kernel.org> - 2017-01-29 01:00 +0100 [PATCH 06/50] x86/boot/e820: Remove spurious asm/e820/api.h inclusions Ingo Molnar <mingo@kernel.org> - 2017-01-29 01:00 +0100 [PATCH 09/50] x86/boot/e820: Remove unnecessary __ASSEMBLY__ guard Ingo Molnar <mingo@kernel.org> - 2017-01-29 01:10 +0100 [PATCH 07/50] x86/boot/e820: Remove assembly guard from asm/e820/types.h Ingo Molnar <mingo@kernel.org> - 2017-01-29 01:10 +0100 [PATCH 18/50] x86/boot/e820: Rename e820_table_saved to e820_table_firmware and improve the description Ingo Molnar <mingo@kernel.org> - 2017-01-29 01:10 +0100 [PATCH 10/50] x86/boot/e820: Move HIGH_MEMORY define to asm/e820/types.h Ingo Molnar <mingo@kernel.org> - 2017-01-29 01:20 +0100 [PATCH 31/50] x86/boot/e820: Rename e820_setup_gap() to e820__setup_pci_gap() Ingo Molnar <mingo@kernel.org> - 2017-01-29 01:20 +0100 [PATCH 42/50] xen, x86/boot/e820: Simplify Xen's xen_e820_table construct Ingo Molnar <mingo@kernel.org> - 2017-01-29 02:10 +0100 [PATCH 32/50] x86/boot/e820: Create coherent API function names for E820 range operations Ingo Molnar <mingo@kernel.org> - 2017-01-29 02:10 +0100
csiph-web