Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1566626

Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA

Path csiph.com!2.eu.feeder.erje.net!feeder.erje.net!1.eu.feeder.erje.net!weretis.net!feeder4.news.weretis.net!storethat.news.telefonica.de!telefonica.de!news.panservice.it!bofh.it!news.nic.it!robomod
From Pavel Machek <pavel@ucw.cz>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA
Date Wed, 25 Jan 2017 15:00:04 +0100
Message-ID <t3whe-2sl-65@gated-at.bofh.it> (permalink)
References <t19RM-3iT-5@gated-at.bofh.it> <t19RM-3iT-3@gated-at.bofh.it> <t1fNv-77q-3@gated-at.bofh.it> <t3tW2-16w-29@gated-at.bofh.it>
MIME-Version 1.0
Content-Type multipart/signed; micalg=pgp-sha1; protocol="application/pgp-signature"; boundary="CE+1k2dSO48ffgeK"
Content-Disposition inline
User-Agent Mutt/1.5.23 (2014-03-12)
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 65
Organization linux.* mail to news gateway
X-Original-Cc Kees Cook <keescook@chromium.org>, Jason Wessel <jason.wessel@windriver.com>, Jonathan Corbet <corbet@lwn.net>, Russell King <linux@armlinux.org.uk>, Catalin Marinas <catalin.marinas@arm.com>, Will Deacon <will.deacon@arm.com>, "James E.J. Bottomley" <jejb@parisc-linux.org>, Helge Deller <deller@gmx.de>, Martin Schwidefsky <schwidefsky@de.ibm.com>, Heiko Carstens <heiko.carstens@de.ibm.com>, Thomas Gleixner <tglx@linutronix.de>, Ingo Molnar <mingo@redhat.com>, "H. Peter Anvin" <hpa@zytor.com>, x86@kernel.org, Rob Herring <robh@kernel.org>, "Rafael J. Wysocki" <rjw@rjwysocki.net>, Len Brown <len.brown@intel.com>, Mark Rutland <mark.rutland@arm.com>, Jessica Yu <jeyu@redhat.com>, linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-parisc@vger.kernel.org, linux-s390@vger.kernel.org, linux-pm@vger.kernel.org, kernel-hardening@lists.openwall.com
X-Original-Date Wed, 25 Jan 2017 14:51:24 +0100
X-Original-Message-ID <20170125135124.GA20896@amd>
X-Original-References <1484789346-21012-1-git-send-email-labbott@redhat.com> <1484789346-21012-2-git-send-email-labbott@redhat.com> <20170119075341.GA14530@amd> <fca01775-9640-8783-a657-a9e6cf0c3e0a@redhat.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1566626

Show key headers only | View raw


[Multipart message — attachments visible in raw view] - view raw

On Wed 2017-01-25 12:21:05, Laura Abbott wrote:
> On 01/19/2017 08:53 AM, Pavel Machek wrote:
> >On Wed 2017-01-18 17:29:05, Laura Abbott wrote:
> >>
> >>Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option
> >>provides key security features that are to be expected on a modern
> >>system. Change the name to CONFIG_HARDENED_PAGE_MAPPINGS which more
> >>accurately describes what this option is intended to do.
> >
> >I think this is bad change. CONFIG_DEBUG_RODATA is describing what it
> >does, CONFIG_HARDENED_PAGE_MAPPINGS is advertising.
> >
> >We don't do advertising, and we don't force people to re-answer the
> >config questions without good reason.
> >
> >CONFIG_HARDENED_RODATA might fix the first problem, but not the second
> >one.
> >
> >								Pavel
> >								
> 
> (Apologies, my SMTP was set up incorrectly so my response didn't
> actually get sent out)
> 
> CONFIG_DEBUG_RODATA isn't describing what it does though. It misses
> that this config may handle much more than just rodata. I think
> Mark Rutland's suggestion of STRICT_KERNEL_RWX might be more
> descriptive.

CONFIG_BUG=y
CONFIG_LBDAF=y
CONFIG_PM_OPP=y

..it is config option. It is not description of the feature. People
are living with that config option for a while. I'd keep it.

Maybe you can go from CONFIG_DEBUG_RODATA to CONFIG_RODATA... (but
you'll still have people re-answer config option.)


								Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-19 02:40 +0100
  Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Pavel Machek <pavel@ucw.cz> - 2017-01-19 09:00 +0100
    Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-25 12:30 +0100
      Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Pavel Machek <pavel@ucw.cz> - 2017-01-25 15:00 +0100
  Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Mark Rutland <mark.rutland@arm.com> - 2017-01-19 12:00 +0100
    Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Heiko Carstens <heiko.carstens@de.ibm.com> - 2017-01-19 12:40 +0100
      Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Helge Deller <deller@gmx.de> - 2017-01-19 22:20 +0100
      Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-25 12:40 +0100
    Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Kees Cook <keescook@chromium.org> - 2017-01-19 23:10 +0100
    Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Laura Abbott <labbott@redhat.com> - 2017-01-25 12:30 +0100
  Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA Kees Cook <keescook@chromium.org> - 2017-01-19 23:10 +0100

csiph-web