Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1564754
| From | Michael Ellerman <mpe@ellerman.id.au> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH tip/core/rcu 2/3] srcu: Force full grace-period ordering |
| Date | 2017-01-23 09:20 +0100 |
| Message-ID | <t2I14-40Y-1@gated-at.bofh.it> (permalink) |
| References | <sZsOR-4dp-11@gated-at.bofh.it> <sZsOT-4dp-41@gated-at.bofh.it> <sZsYy-4gr-7@gated-at.bofh.it> <sZJZn-60P-21@gated-at.bofh.it> <sZJZn-60P-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
"Paul E. McKenney" <paulmck@linux.vnet.ibm.com> writes:
> On Sat, Jan 14, 2017 at 11:54:17AM -0800, Paul E. McKenney wrote:
>> On Sat, Jan 14, 2017 at 10:35:50AM +0100, Ingo Molnar wrote:
>> > * Paul E. McKenney <paulmck@linux.vnet.ibm.com> wrote:
>
> [ . . . ]
>
>> > > + */
>> > > +#ifdef CONFIG_PPC
>> > > +#define smp_mb__after_unlock_lock() smp_mb() /* Full ordering for lock. */
>> > > +#else /* #ifdef CONFIG_PPC */
>> > > +#define smp_mb__after_unlock_lock() do { } while (0)
>> > > +#endif /* #else #ifdef CONFIG_PPC */
>> >
>> > Yeah, so I realize that this was pre-existing code, but putting CONFIG_$ARCH
>> > #ifdefs into generic headers is generally frowned upon.
>> >
>> > The canonical approach would be either to define a helper Kconfig variable that
>> > can be set by PPC (but other architectures don't need to set it), or to expose a
>> > suitable macro (function) for architectures to define in their barrier.h arch
>> > header file.
>>
>> Very well, I will add a separate commit for this. 4.11 OK?
>
> Does the patch below seem reasonable?
>
> Thanx, Paul
>
> ------------------------------------------------------------------------
>
> commit 271c0601237c41a279f975563e13837bace0df03
> Author: Paul E. McKenney <paulmck@linux.vnet.ibm.com>
> Date: Sat Jan 14 13:32:50 2017 -0800
>
> rcu: Make arch select smp_mb__after_unlock_lock() strength
>
> The definition of smp_mb__after_unlock_lock() is currently smp_mb()
> for CONFIG_PPC and a no-op otherwise. It would be better to instead
> provide an architecture-selectable Kconfig option, and select the
> strength of smp_mb__after_unlock_lock() based on that option. This
> commit therefore creates CONFIG_ARCH_WEAK_RELACQ, has PPC select it,
> and bases the definition of smp_mb__after_unlock_lock() on this new
> CONFIG_ARCH_WEAK_RELACQ Kconfig option.
>
> Reported-by: Ingo Molnar <mingo@kernel.org>
> Signed-off-by: Paul E. McKenney <paulmck@linux.vnet.ibm.com>
> Cc: Peter Zijlstra <peterz@infradead.org>
> Cc: Will Deacon <will.deacon@arm.com>
> Cc: Boqun Feng <boqun.feng@linux.vnet.ibm.com>
> Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
> Cc: Paul Mackerras <paulus@samba.org>
> Cc: Michael Ellerman <mpe@ellerman.id.au>
> Cc: <linuxppc-dev@lists.ozlabs.org>
Personally I'd call it ARCH_WEAK_RELEASE_ACQUIRE, which is longer but
clearer I think. But it's not a big deal, so which ever you prefer.
Acked-by: Michael Ellerman <mpe@ellerman.id.au>
cheers
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH tip/core/rcu 2/3] srcu: Force full grace-period ordering Michael Ellerman <mpe@ellerman.id.au> - 2017-01-23 09:20 +0100 Re: [PATCH tip/core/rcu 2/3] srcu: Force full grace-period ordering "Paul E. McKenney" <paulmck@linux.vnet.ibm.com> - 2017-01-24 03:50 +0100
csiph-web