Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1564139
| From | Zhihui Zhang <zzhsuny@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] timers: Reconcile the code and the comment for the 250HZ case |
| Date | 2017-01-21 16:10 +0100 |
| Message-ID | <t25sJ-5uL-7@gated-at.bofh.it> (permalink) |
| References | <sVibo-4qO-9@gated-at.bofh.it> <t1Qam-4J3-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Sure, I believe that comments should always match the code. In this case, using either LVL_SIZE - 1 or LVL_SIZE is fine based on my understanding about 20 days ago. But I could be wrong and miss some subtle details. Anyway, my point is about readability. thanks, On Fri, Jan 20, 2017 at 5:41 PM, John Stultz <john.stultz@linaro.org> wrote: > On Mon, Jan 2, 2017 at 1:14 PM, Zhihui Zhang <zzhsuny@gmail.com> wrote: >> Adjust the time start of each level to match the comments. Note that >> LVL_START(n) is never used for n = 0 case. Also, each level (except >> level 0) has more than enough room to accommodate all its timers. > > So instead of just covering what your patch does, can you explain in > some detail why this patch is useful? What net effect does it bring? > What sort of bugs would it solve? > > thanks > -john
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH] timers: Reconcile the code and the comment for the 250HZ case John Stultz <john.stultz@linaro.org> - 2017-01-20 23:50 +0100
Re: [PATCH] timers: Reconcile the code and the comment for the 250HZ case Zhihui Zhang <zzhsuny@gmail.com> - 2017-01-21 16:10 +0100
Re: [PATCH] timers: Reconcile the code and the comment for the 250HZ case Thomas Gleixner <tglx@linutronix.de> - 2017-01-23 12:20 +0100
Re: [PATCH] timers: Reconcile the code and the comment for the 250HZ case Zhihui Zhang <zzhsuny@gmail.com> - 2017-01-25 01:00 +0100
csiph-web