Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1563127
| From | Kees Cook <keescook@chromium.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC][PATCH 0/2] Better hardening names |
| Date | 2017-01-19 23:10 +0100 |
| Message-ID | <t1t45-7iz-13@gated-at.bofh.it> (permalink) |
| References | <t19RM-3iT-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Jan 18, 2017 at 5:29 PM, Laura Abbott <labbott@redhat.com> wrote: > Hi, > > It's come up previously that CONFIG_DEBUG_SET_MODULE_RONX and > CONFIG_DEBUG_RODATA are not accurate names, mostly they should not have the > word 'debug' in them. This series attempts to change the names to something > a bit more descriptive and indicative of what they are actually used for these > days. > > I marked this RFC for > - Bike shedding purposes. > - A discussion of what defaults should be. The way I did the refactoring, both > options are default y. I'd appreciate comments if there is a better approach. > - Approach to split this up into more sub patches to make review/merging easier? > Or maybe it's fine. > > Quickly tested on arm/arm64/x86. > > Thanks, > Laura > > Laura Abbott (2): > security: Change name of CONFIG_DEBUG_RODATA > security: Change name of CONFIG_DEBUG_SET_MODULE_RONX Some day I'll quit reading my email backwards. :) I see you've got MODULE_RONX renamed too here, please ignore my comment about needing it "too". :) -Kees -- Kees Cook Nexus Security
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[RFC][PATCH 0/2] Better hardening names Laura Abbott <labbott@redhat.com> - 2017-01-19 02:40 +0100 Re: [RFC][PATCH 0/2] Better hardening names Kees Cook <keescook@chromium.org> - 2017-01-19 23:10 +0100
csiph-web