Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1562109
| From | Paul Gortmaker <paul.gortmaker@windriver.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] lib: sort: make it explicitly non-modular |
| Date | 2017-01-18 20:40 +0100 |
| Message-ID | <t14fn-8aj-7@gated-at.bofh.it> (permalink) |
| References | <t11hw-6lt-21@gated-at.bofh.it> <t12Qi-7py-25@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Re: [PATCH] lib: sort: make it explicitly non-modular] On 18/01/2017 (Wed 20:03) Andy Shevchenko wrote: > On Wed, Jan 18, 2017 at 6:20 PM, Paul Gortmaker > <paul.gortmaker@windriver.com> wrote: > > The Makefile currently controlling compilation of this code is: > > > > lib/Kconfig.debug:config TEST_SORT > > lib/Kconfig.debug: bool "Array-based sort test" > > > > and... > > > > lib/Makefile:obj-y += bcd.o div64.o sort.o [...] > > > > ...meaning that it currently is not being built as a module by anyone. > > Perhaps allow it to be a module? If anything, I'd argue the other way and say we shouldn't be further polluting Kconfig space with more super specific options. Instead something more generic like CONFIG_ENABLE_BOOT_SELF_TESTS that at least could be shared. There is no real value in making something a module when it could just as easily be thrown out as __init code/data. > > Besides that perhaps rename to something like test_sort.c ? The sort.c was not added just for the test code ; it already existed for the sort code itself. Paul. -- > > -- > With Best Regards, > Andy Shevchenko
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] lib: sort: make it explicitly non-modular Paul Gortmaker <paul.gortmaker@windriver.com> - 2017-01-18 17:30 +0100
Re: [PATCH] lib: sort: make it explicitly non-modular Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-01-18 19:10 +0100
Re: [PATCH] lib: sort: make it explicitly non-modular Paul Gortmaker <paul.gortmaker@windriver.com> - 2017-01-18 20:40 +0100
Re: [PATCH] lib: sort: make it explicitly non-modular Felix Kostenzer <fkostenzer@live.at> - 2017-01-18 21:40 +0100
Re: [PATCH] lib: sort: make it explicitly non-modular Paul Gortmaker <paul.gortmaker@windriver.com> - 2017-01-19 01:50 +0100
csiph-web