Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1561344
| From | Ritesh Harjani <riteshh@codeaurora.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RESEND PATCHv1 0/8] mmc: sdhci-msm: Provide support for enhanced strobe |
| Date | 2017-01-18 09:00 +0100 |
| Message-ID | <t0TjZ-1fI-13@gated-at.bofh.it> (permalink) |
| References | <sXYJb-6JW-5@gated-at.bofh.it> <t0qrD-f1-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 1/17/2017 6:37 AM, Jeremy McNicoll wrote:
> On Tue, Jan 10, 2017 at 12:30:44PM +0530, Ritesh Harjani wrote:
>> Hi,
>>
>> Resending this patch series, as no one could review it -possibly due to
>> holidays during that time.
>>
>> This patch series mainly provides enhanced strobe support to sdhci-msm driver
>> along with some additions of HW recommended sequence. This has been tested on
>> 8996 based internal target & on db410c.
>>
>> Patches 1-3 :- Factors out few functions to be re-used again.
>> To also simplify large functions and makes it more readable.
>>
>> Patches 4-5 :- Few recommendations based on HW prog. guide.
>>
>> Patches 6 :- Clear SDHCI_HS400_TUNING flag after platform_execute_tuning
>> so that ->platform_execute_tuning (underlying platform driver) can
>> know about HS400 tuning.
>>
>> Patch 7 :- Implements an additional step as per HPG for HS400 tuning.
>>
>> Patch 8 :- Implements enhanced strobe functionality in sdhci-msm driver.
>>
>>
>
> I have included this series in my tree while testing my SDHCI V2 series.
>
> One message did occur which looks new or unfamilar and relatively
> harmless,
>
> "sdhci_msm f9824900.mmc: TCXO clk not present (-2) "
This should be ok.
>
> Is that something I am missing on my side?
You should provide this in your DT.
@@ -463,8 +463,9 @@
interrupts = <0 141 0>, <0 134 0>;
interrupt-names = "hc_irq", "pwr_irq";
clocks = <&gcc GCC_SDCC1_APPS_CLK>,
- <&gcc GCC_SDCC1_AHB_CLK>;
- clock-names = "core", "iface";
+ <&gcc GCC_SDCC1_AHB_CLK>,
+ <&xo_board>;
+ clock-names = "core", "iface", "xo";
>
> In anycase,
>
> Tested-by: Jeremy McNicoll <jeremymc@redhat.com>
Thanks for testing this series.
Hi Adrian/Ulf,
In case if we dont have any other comments, can we please include this
series in next ?
--
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [RESEND PATCHv1 0/8] mmc: sdhci-msm: Provide support for enhanced strobe Jeremy McNicoll <jmcnicol@redhat.com> - 2017-01-17 02:10 +0100 Re: [RESEND PATCHv1 0/8] mmc: sdhci-msm: Provide support for enhanced strobe Ritesh Harjani <riteshh@codeaurora.org> - 2017-01-18 09:00 +0100
csiph-web