Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1560784

[PATCH 0/8] drm/mali-dp: Fixes for v4.11

From Liviu Dudau <Liviu.Dudau@arm.com>
Newsgroups linux.kernel
Subject [PATCH 0/8] drm/mali-dp: Fixes for v4.11
Date 2017-01-17 17:40 +0100
Message-ID <t0EXE-VQ-31@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Hello,

Here is the collected list of patches that I have accumulated since last
December in my inbox. They are offered for review and comments before
I commit them to the mali-dp tree and they get added to linux-next.

Best regards,
Liviu

Brian Starkey (4):
  drm: mali-dp: Don't force source size == crtc size
  drm: mali-dp: Fix destination size handling when rotating
  drm: mali-dp: Fix transposed horizontal/vertical flip
  drm: mali-dp: Rename malidp_input_format to malidp_pixel_format

Liviu Dudau (2):
  drm: malidp: Remove event_list member from struct malidp_drm
  drm: mali-dp: Check more use cases in the plane's ->atomic_check()

Mihail Atanassov (1):
  drm: mali-dp: fix Lx_CONTROL register fields clobber

Shailendra Verma (1):
  drm/arm/malidp: Fix possible dereference of NULL

 drivers/gpu/drm/arm/malidp_drv.c    |  2 --
 drivers/gpu/drm/arm/malidp_drv.h    |  2 +-
 drivers/gpu/drm/arm/malidp_hw.c     | 24 ++++++++--------
 drivers/gpu/drm/arm/malidp_hw.h     |  8 +++---
 drivers/gpu/drm/arm/malidp_planes.c | 57 +++++++++++++++++++++----------------
 5 files changed, 50 insertions(+), 43 deletions(-)

-- 
2.11.0

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 0/8] drm/mali-dp: Fixes for v4.11 Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:40 +0100
  [PATCH 5/8] drm: mali-dp: Fix destination size handling when rotating Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:40 +0100
  [PATCH 4/8] drm: mali-dp: Don't force source size == crtc size Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:50 +0100
  [PATCH 2/8] drm: malidp: Remove event_list member from struct malidp_drm Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:50 +0100
  [PATCH 1/8] drm/arm/malidp: Fix possible dereference of NULL Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:50 +0100
  [PATCH 7/8] drm: mali-dp: fix Lx_CONTROL register fields clobber Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:50 +0100
  [PATCH 3/8] drm: mali-dp: Check more use cases in the plane's ->atomic_check() Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:50 +0100
  [PATCH 8/8] drm: mali-dp: Rename malidp_input_format to malidp_pixel_format Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:50 +0100
  [PATCH 6/8] drm: mali-dp: Fix transposed horizontal/vertical flip Liviu Dudau <Liviu.Dudau@arm.com> - 2017-01-17 17:50 +0100

csiph-web