Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1515063

Re: [PATCH 10/34] [media] DaVinci-VPBE: Check return value of a setup_if_config() call in vpbe_set_output()

From Hans Verkuil <hverkuil@xs4all.nl>
Newsgroups linux.kernel
Subject Re: [PATCH 10/34] [media] DaVinci-VPBE: Check return value of a setup_if_config() call in vpbe_set_output()
Date 2016-11-04 09:10 +0100
Message-ID <szHJv-7wH-9@gated-at.bofh.it> (permalink)
References <srsHD-5Fa-11@gated-at.bofh.it> <srt10-5LT-19@gated-at.bofh.it> <szpjA-3NI-45@gated-at.bofh.it> <szxh7-sf-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 03/11/16 21:54, SF Markus Elfring wrote:
>>> From: Markus Elfring <elfring@users.sourceforge.net>
>>> Date: Wed, 12 Oct 2016 09:56:56 +0200
>>>
>>> * A function was called over the pointer "setup_if_config" in the data
>>>   structure "venc_platform_data". But the return value was not used so far.
>>>   Thus assign it to the local variable "ret" which will be checked with
>>>   the next statement.
>>>
>>>   Fixes: 9a7f95ad1c946efdd7a7a72df27db738260a0fd8 ("[media] davinci vpbe: add dm365 VPBE display driver changes")
>>>
>>> * Pass a value to this function call without storing it in an intermediate
>>>   variable before.
>>>
>>> * Delete the local variable "if_params" which became unnecessary with
>>>   this refactoring.
>>>
>>> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
>>> ---
>>>  drivers/media/platform/davinci/vpbe.c | 5 ++---
>>>  1 file changed, 2 insertions(+), 3 deletions(-)
>>>
>>> diff --git a/drivers/media/platform/davinci/vpbe.c b/drivers/media/platform/davinci/vpbe.c
>>> index 19611a2..6e7b0df 100644
>>> --- a/drivers/media/platform/davinci/vpbe.c
>>> +++ b/drivers/media/platform/davinci/vpbe.c
>>> @@ -227,7 +227,6 @@ static int vpbe_set_output(struct vpbe_device *vpbe_dev, int index)
>>>              vpbe_current_encoder_info(vpbe_dev);
>>>      struct vpbe_config *cfg = vpbe_dev->cfg;
>>>      struct venc_platform_data *venc_device = vpbe_dev->venc_device;
>>> -    u32 if_params;
>>>      int enc_out_index;
>>>      int sd_index;
>>>      int ret = 0;
>>> @@ -257,8 +256,8 @@ static int vpbe_set_output(struct vpbe_device *vpbe_dev, int index)
>>>              goto out;
>>>          }
>>>
>>> -        if_params = cfg->outputs[index].if_params;
>>> -        venc_device->setup_if_config(if_params);
>>> +        ret = venc_device->setup_if_config(cfg
>>> +                           ->outputs[index].if_params);
>>
>> Either keep this as one line
>
> Will you tolerate a line length of 82 characters then?

Yes, if it improves readability, which it does.

>
>
>> or keep the if_params temp variable.
>
> My proposal was to get rid of it.
>
>
>> This odd linebreak is ugly.
>
> I am curious on how the desired changes can be integrated after a couple of update
> suggestions were accepted from this patch series.

See my previous reply to 17/34.

Regards,

	Hans

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH 10/34] [media] DaVinci-VPBE: Check return value of a  setup_if_config() call in vpbe_set_output() Hans Verkuil <hverkuil@xs4all.nl> - 2016-11-03 13:30 +0100
  Re: [PATCH 10/34] [media] DaVinci-VPBE: Check return value of a  setup_if_config() call in vpbe_set_output() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-11-03 22:00 +0100
    Re: [PATCH 10/34] [media] DaVinci-VPBE: Check return value of a  setup_if_config() call in vpbe_set_output() Hans Verkuil <hverkuil@xs4all.nl> - 2016-11-04 09:10 +0100
      [PATCH v2 10/34] [media] DaVinci-VPBE: Check return value of a  setup_if_config() call in vpbe_set_output() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-11-06 21:10 +0100

csiph-web