Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1513115
| From | Lukasz Majewski <l.majewski@majess.pl> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v3 00/11] pwm: imx: Provide atomic operation for IMX PWM driver |
| Date | 2016-11-01 08:20 +0100 |
| Message-ID | <syBwt-5xk-1@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
This patch set brings atomic operation to i.MX's PWMv2 driver.
This work has been supported and suggested by Boris Brezillon [1] and
Stefan Agner, by showing how simple the transition could be :-).
It has been divided into several steps:
- Remove ipg clock enable/disable code (as proposed by Sascha Hauer) - this
is the most notable change for v3
- Provide different pwm ops for PWMv1 and PWMv2
- Separate PWMv1 commits from "generic" and non atomic PWM code
NOTE: Since I do _not_ have board with PWMv1, I would like to ask somebody
for testing
- Move some imx_config_v2 code to separate functions
- Provide PWM atomic implementation (the ->apply() driver) for PWMv2 in a
single patch for better readability.
- Remove redundant PWM code (disable, enable, config callbacks)
- Update proper documentation entries
- Provide support for polarity inversion on top of atomic PWM rework
Test HW:
--------
This patch set has been tested on i.MX6q board with
v4.9-rc3 kernel SHA1: a909d3e636995ba7c349e2ca5dbb528154d4ac30
The PWM operation has been tested with pwm_bl backlight driver by changing
its brightness.
[1]: http://patchwork.ozlabs.org/patch/685402/
Lothar Wassmann (2):
pwm: print error messages with pr_err() instead of pr_debug()
pwm: core: make the PWM_POLARITY flag in DTB optional
Lukasz Majewski (8):
pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2
pwm: imx: Rewrite imx_pwm_*_v1 code to facilitate switch to atomic pwm
operation
pwm: imx: Move PWMv2 software reset code to a separate function
pwm: imx: Move PWMv2 wait for fifo slot code to a separate function
pwm: imx: Provide atomic PWM support for i.MX PWMv2
pwm: imx: Remove redundant i.MX PWMv2 code
pwm: imx: doc: Update imx-pwm.txt documentation entry
pwm: imx: Add polarity inversion support to i.MX's PWMv2
Sascha Hauer (1):
pwm: imx: remove ipg clock
Documentation/devicetree/bindings/pwm/imx-pwm.txt | 6 +-
drivers/pwm/core.c | 26 +--
drivers/pwm/pwm-imx.c | 247 ++++++++++------------
3 files changed, 134 insertions(+), 145 deletions(-)
--
2.1.4
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v3 00/11] pwm: imx: Provide atomic operation for IMX PWM driver Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
[PATCH v3 08/11] pwm: imx: Remove redundant i.MX PWMv2 code Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
[PATCH v3 05/11] pwm: imx: Move PWMv2 software reset code to a separate function Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
[PATCH v3 03/11] pwm: imx: Add separate set of pwm ops for PWMv1 and PWMv2 Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
[PATCH v3 04/11] pwm: imx: Rewrite imx_pwm_*_v1 code to facilitate switch to atomic pwm operation Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
[PATCH v3 02/11] pwm: imx: remove ipg clock Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
Re: [PATCH v3 02/11] pwm: imx: remove ipg clock Philipp Zabel <p.zabel@pengutronix.de> - 2016-11-01 10:30 +0100
[PATCH v3 10/11] pwm: imx: doc: Update imx-pwm.txt documentation entry Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
[PATCH v3 01/11] pwm: print error messages with pr_err() instead of pr_debug() Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:20 +0100
[PATCH v3 11/11] pwm: imx: Add polarity inversion support to i.MX's PWMv2 Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:30 +0100
[PATCH v3 09/11] pwm: core: make the PWM_POLARITY flag in DTB optional Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:30 +0100
[PATCH v3 07/11] pwm: imx: Provide atomic PWM support for i.MX PWMv2 Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:40 +0100
[PATCH v3 06/11] pwm: imx: Move PWMv2 wait for fifo slot code to a separate function Lukasz Majewski <l.majewski@majess.pl> - 2016-11-01 08:40 +0100
Re: [PATCH v3 00/11] pwm: imx: Provide atomic operation for IMX PWM driver Lukasz Majewski <l.majewski@majess.pl> - 2016-11-08 23:30 +0100
csiph-web