Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1510445
| From | Frank Rowand <frowand.list@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter |
| Date | 2016-10-27 18:10 +0200 |
| Message-ID | <swVpE-49R-31@gated-at.bofh.it> (permalink) |
| References | <swh8R-2vP-3@gated-at.bofh.it> <swh8T-2vP-65@gated-at.bofh.it> <swTnR-2Bn-87@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 10/27/16 05:21, Rob Herring wrote:
> On Tue, Oct 25, 2016 at 3:58 PM, <frowand.list@gmail.com> wrote:
>> From: Frank Rowand <frank.rowand@am.sony.com>
>
> Maybe some should be debug?
>
>> Signed-off-by: Frank Rowand <frank.rowand@am.sony.com>
>> ---
>> drivers/of/resolver.c | 28 ----------------------------
>> 1 file changed, 28 deletions(-)
>>
>> diff --git a/drivers/of/resolver.c b/drivers/of/resolver.c
>> index 4ff0220d7aa2..93a7ca0bf98c 100644
>> --- a/drivers/of/resolver.c
>> +++ b/drivers/of/resolver.c
>> @@ -116,8 +116,6 @@ static int __of_adjust_phandle_ref(struct device_node *node,
>>
>> propval = kmalloc(rprop->length, GFP_KERNEL);
>> if (!propval) {
>> - pr_err("%s: Could not copy value of '%s'\n",
>> - __func__, rprop->name);
>> return -ENOMEM;
>> }
>
> I would remove the brackets in this patch rather than separately.
>
>> memcpy(propval, rprop->value, rprop->length);
> .
>
OK, I will collapse the "remove braces" patch into this patch.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 05/13] of: Rename functions to more accurately reflect what they do frowand.list@gmail.com - 2016-10-25 23:10 +0200
Re: [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable Frank Rowand <frowand.list@gmail.com> - 2016-10-25 23:10 +0200
Re: [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-10-27 16:00 +0200
Re: [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable Rob Herring <robh+dt@kernel.org> - 2016-10-27 16:40 +0200
Re: [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable Frank Rowand <frowand.list@gmail.com> - 2016-10-27 18:40 +0200
[RFC PATCH 09/13] of: Remove redundant size check frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 03/13] of: Remove braces around single line blocks. frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 08/13] of: Update structure of code, remove BUG_ON() frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 07/13] of: Rename variables to better reflect purpose or follow convention frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names frowand.list@gmail.com - 2016-10-25 23:10 +0200
Re: [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names Rob Herring <robh+dt@kernel.org> - 2016-10-27 16:20 +0200
Re: [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names Frank Rowand <frowand.list@gmail.com> - 2016-10-27 18:40 +0200
Re: [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names Rob Herring <robh+dt@kernel.org> - 2016-10-27 19:00 +0200
Re: [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names Frank Rowand <frowand.list@gmail.com> - 2016-10-27 20:30 +0200
Re: [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names Rob Herring <robh+dt@kernel.org> - 2016-10-27 22:30 +0200
[RFC PATCH 01/13] of: Remove comments that state the obvious frowand.list@gmail.com - 2016-10-25 23:10 +0200
Re: [RFC PATCH 01/13] of: Remove comments that state the obvious Joe Perches <joe@perches.com> - 2016-10-25 23:40 +0200
Re: [RFC PATCH 01/13] of: Remove comments that state the obvious Rob Herring <robh+dt@kernel.org> - 2016-10-27 16:50 +0200
Re: [RFC PATCH 01/13] of: Remove comments that state the obvious Frank Rowand <frowand.list@gmail.com> - 2016-10-27 18:10 +0200
[RFC PATCH 04/13] of: Convert comparisons to zero or NULL to simplify logical expressions frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 12/13] of: Move setting of pointer to beside test for non-null frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 10/13] of: Update comments to reflect changes and increase clarity frowand.list@gmail.com - 2016-10-25 23:10 +0200
[RFC PATCH 02/13] of: Remove excessive printks to reduce clutter frowand.list@gmail.com - 2016-10-25 23:10 +0200
Re: [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-10-27 16:00 +0200
Re: [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter Frank Rowand <frowand.list@gmail.com> - 2016-10-27 18:20 +0200
Re: [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter Rob Herring <robh+dt@kernel.org> - 2016-10-27 17:00 +0200
Re: [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter Frank Rowand <frowand.list@gmail.com> - 2016-10-27 18:10 +0200
csiph-web