Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1507575

Re: [PATCH 1/1] checkpatch: remove false warning for commit reference

From Andy Whitcroft <apw@canonical.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/1] checkpatch: remove false warning for commit reference
Date 2016-10-24 20:50 +0200
Message-ID <svStP-31f-9@gated-at.bofh.it> (permalink)
References <rIFUl-4Uy-7@gated-at.bofh.it> <svlHz-6sb-11@gated-at.bofh.it> <svxIK-5Gc-19@gated-at.bofh.it> <svRep-2gd-27@gated-at.bofh.it> <svStP-31f-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Oct 24, 2016 at 11:39:45AM -0700, Joe Perches wrote:
> On Mon, 2016-10-24 at 19:22 +0200, Heinrich Schuchardt wrote:
> > On 10/23/2016 10:37 PM, Joe Perches wrote:
> > > On Sun, 2016-10-23 at 09:34 +0200, Heinrich Schuchardt wrote:
> > > > Checkpatch warns of an incorrect commit reference style
> > > > for any hexadecimal number of 12 digits and more.
> > > > 
> > > > Numbers of 12 digits are not necessarily commit ids.
> > > > 
> > > > For an example provoking the problem see
> > > > https://patchwork.kernel.org/patch/9170897/
> > > > 
> > > > Checkpatch should only warn if the number refers to an
> > > > existing commit.
> > > 
> > > That seems sensible.
> > > 
> > > > Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
> > > > ---
> > > >  scripts/checkpatch.pl | 5 ++++-
> > > >  1 file changed, 4 insertions(+), 1 deletion(-)
> > > > 
> > > > diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> > > 
> > > []
> > > > @@ -848,6 +848,7 @@ sub git_commit_info {
> > > >  #		    echo "commit $(cut -c 1-12,41-)"
> > > >  #		done
> > > >  	} elsif ($lines[0] =~ /^fatal: ambiguous argument '$commit': unknown revision or path not in the working tree\./) {
> > > > +		$id = undef;
> > > 
> > > OK
> > > 
> > > >  	} else {
> > > >  		$id = substr($lines[0], 0, 12);
> > > >  		$desc = substr($lines[0], 41);
> > > > @@ -2577,7 +2578,9 @@ sub process {
> > > >  			($id, $description) = git_commit_info($orig_commit,
> > > >  							      $id, $orig_desc);
> > > >  
> > > > -			if ($short || $long || $space || $case || ($orig_desc ne $description) || !$hasparens) {
> > > > +			if ($id && ($short || $long || $space || $case
> > > > +				|| ($orig_desc ne $description)
> > > > +				|| !$hasparens)) {
> > > 
> > > I'd prefer
> > > 			if (defined($id) &&
> > 
> > For $id = 0 or $id = "" this would make a difference.
> > Surely I can update the patch like this to make the test more readable.
> > 
> > > 			   ($short || $long || $space || $case || ($orig_desc ne $description) || !$hasparens)) {
> > > 
> > > and not wrap the tests.
> > 
> > Putting defined($id) on a line of its own is fine.
> > 
> > Not wrapping the tests will produce a line of over 80 characters and
> > give a warning in scripts/checkpatch.pl.
> > 
> > The script should respect the standards it imposes on others.
> 
> Nope.
> 
> I never bother using checkpatch on checkpatch.
> perl is unreadable enough with having to wrap long and
> complex regexes on 80 columns.

More specifically checkpatch is primarily checking C language construction
to keep the style of the Linux kernel consistent.  The rules were never
really intended to apply to perl or other languages.  We have long leant
towards longer lines in checkpatch for some kind of readability, as much
as you can have in "systactic sugar overload" language.

-apw

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/1] checkpatch: remove false warning for commit reference Heinrich Schuchardt <xypron.glpk@gmx.de> - 2016-10-23 09:50 +0200
  Re: [PATCH 1/1] checkpatch: remove false warning for commit  reference Joe Perches <joe@perches.com> - 2016-10-23 22:40 +0200
    Re: [PATCH 1/1] checkpatch: remove false warning for commit reference Heinrich Schuchardt <xypron.glpk@gmx.de> - 2016-10-24 19:30 +0200
      Re: [PATCH 1/1] checkpatch: remove false warning for commit reference Andy Whitcroft <apw@canonical.com> - 2016-10-24 20:50 +0200
        [PATCH] checkpatch: Don't check .pl files, improve absolute path commit log test Joe Perches <joe@perches.com> - 2016-10-24 22:20 +0200
      Re: [PATCH 1/1] checkpatch: remove false warning for commit  reference Joe Perches <joe@perches.com> - 2016-10-24 20:50 +0200

csiph-web