Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1499192
| From | Zach Brown <zach.brown@ni.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v4 0/3] Add support for led triggers on phy link state change |
| Date | 2016-10-11 22:30 +0200 |
| Message-ID | <srbQt-2QB-7@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Fix skge driver that declared enum contants that conflicted with enum
constants in linux/leds.h
Create function that encapsulates actions taken during the adjust phy link step
of phy state changes.
Add support for led triggers on phy link state changes by adding
a config option. When set the config option will create a set of led triggers
for each phy device. Users can use the led triggers to represent link state
changes on the phy.
v2:
* New patch that creates phy_adjust_link function to encapsulate actions taken
when adjusting phy link during phy state changes
* led trigger speed strings changed to match existing phy speed strings
* New function that maps speeds to led triggers
* Replace magic constants with definitions when declaring trigger name
buffer and number of triggers.
v3:
* Changed LED_ON to LED_REG_ON in skge driver to avoid possible future
conflict and improve consistency.
* Dropped rtl8712 patch that was accepted separately.
v4:
* tweaked commit message
Josh Cartwright (1):
net: phy: leds: add support for led triggers on phy link state change
Zach Brown (2):
skge: Rename LED_OFF and LED_ON in marvel skge driver to avoid
conflicts with leds namespace
net: phy: Encapsulate actions performed during link state changes into
function phy_adjust_link
drivers/net/ethernet/marvell/skge.c | 6 +-
drivers/net/ethernet/marvell/skge.h | 4 +-
drivers/net/phy/Kconfig | 13 +++-
drivers/net/phy/Makefile | 1 +
drivers/net/phy/phy.c | 22 ++++---
drivers/net/phy/phy_device.c | 4 ++
drivers/net/phy/phy_led_triggers.c | 121 ++++++++++++++++++++++++++++++++++++
include/linux/phy.h | 9 +++
include/linux/phy_led_triggers.h | 52 ++++++++++++++++
9 files changed, 218 insertions(+), 14 deletions(-)
create mode 100644 drivers/net/phy/phy_led_triggers.c
create mode 100644 include/linux/phy_led_triggers.h
--
2.7.4
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v4 0/3] Add support for led triggers on phy link state change Zach Brown <zach.brown@ni.com> - 2016-10-11 22:30 +0200
[PATCH v4 2/3] net: phy: Encapsulate actions performed during link state changes into function phy_adjust_link Zach Brown <zach.brown@ni.com> - 2016-10-11 22:30 +0200
[PATCH v4 1/3] skge: Rename LED_OFF and LED_ON in marvel skge driver to avoid conflicts with leds namespace Zach Brown <zach.brown@ni.com> - 2016-10-11 22:30 +0200
Re: [PATCH v4 1/3] skge: Rename LED_OFF and LED_ON in marvel skge driver to avoid conflicts with leds namespace Stephen Hemminger <stephen@networkplumber.org> - 2016-10-11 23:20 +0200
csiph-web