Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1496802
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: md/raid10: Replace printk() calls by the usage of higher level interfaces |
| Date | 2016-10-06 20:40 +0200 |
| Message-ID | <splKi-4z5-13@gated-at.bofh.it> (permalink) |
| References | (3 earlier) <spjSa-2Un-37@gated-at.bofh.it> <spkEy-3Bo-23@gated-at.bofh.it> <spkOd-3Hh-27@gated-at.bofh.it> <splhf-4du-5@gated-at.bofh.it> <splqV-4mC-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
>> Would it be nicer if a single call will be sufficient for such a log message? >> >> Can an idea picked up which was discussed for the update suggestion >> "[PATCH 4/4] Input-gameport: Replace some printk() calls by pr_info() in joydump_connect()" >> for a moment (on 2016-09-24)? >> https://lkml.kernel.org/r/<1474735656.23838.6.camel@perches.com>; >> https://lkml.org/lkml/2016/9/24/149 > > That'd be great. > Pease come back only after you've implemented that. Does this use case show another improvement opportunity for involved software developers (besides me)? Are there any more contributors around who would like to tackle such a challenge? Regards, Markus
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
MD-RAID: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:40 +0200
[PATCH 33/54] md/raid5: Replace printk() calls by the usage of higher level interfaces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:40 +0200
[PATCH 34/54] md/raid5: Delete indentation for two jump labels SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:40 +0200
[PATCH 35/54] md/raid5: Adjust 13 checks for null pointers SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:40 +0200
[PATCH 36/54] md/raid5: Delete four unwanted spaces behind function names SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:40 +0200
[PATCH 43/54] md/raid10: Return directly after detection of unsupported settings in setup_conf() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 42/54] md/raid10: Delete an error message for a failed memory allocation SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 46/54] md/raid10: Less function calls in setup_conf() after error detection SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 47/54] md/raid10: Improve another size determination in raid10_start_reshape() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 48/54] md/raid10: Move a brace for a designated initialiser SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 41/54] md/raid10: Improve another size determination in setup_conf() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 45/54] md/raid10: Move assignments for the variable "err" in setup_conf() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 39/54] md/raid5: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 44/54] md/raid10: Return directly after a failed kzalloc() in setup_conf() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 49/54] md/raid10: Replace printk() calls by the usage of higher level interfaces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
Re: [PATCH 49/54] md/raid10: Replace printk() calls by the usage of higher level interfaces Joe Perches <coupons@perches.com> - 2016-10-06 18:40 +0200
Re: [PATCH 49/54] md/raid10: Replace printk() calls by the usage of higher level interfaces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 19:30 +0200
Re: [PATCH 49/54] md/raid10: Replace printk() calls by the usage of higher level interfaces Joe Perches <joe@perches.com> - 2016-10-06 19:40 +0200
Re: md/raid10: Replace printk() calls by the usage of higher level interfaces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 20:10 +0200
Re: md/raid10: Replace printk() calls by the usage of higher level interfaces Joe Perches <joe@perches.com> - 2016-10-06 20:20 +0200
Re: md/raid10: Replace printk() calls by the usage of higher level interfaces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 20:40 +0200
[PATCH 40/54] md/raid10: Use kcalloc() in two functions SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 11:50 +0200
[PATCH 53/54] md/raid10: Delete two unwanted spaces behind asterisks SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 12:00 +0200
[PATCH 52/54] md/raid10: Replace a seq_printf() call by seq_puts() in raid10_status() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 12:00 +0200
[PATCH 50/54] md/raid10: Delete indentation for one jump label SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 12:00 +0200
[PATCH 54/54] md/raid10: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 12:00 +0200
[PATCH 51/54] md/raid10: Adjust 22 checks for null pointers SF Markus Elfring <elfring@users.sourceforge.net> - 2016-10-06 12:00 +0200
csiph-web