Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1497377

Re: [PATCH v2 0/4] ACPI / gpio: Updates to properties

From Andy Shevchenko <andy.shevchenko@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 0/4] ACPI / gpio: Updates to properties
Date 2016-10-07 19:20 +0200
Message-ID <spGYp-3AS-21@gated-at.bofh.it> (permalink)
References <smJSO-4KE-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Sep 29, 2016 at 4:39 PM, Mika Westerberg
<mika.westerberg@linux.intel.com> wrote:
> Hi,
>
> This series brings couple of useful GPIO related properties from Device
> Tree to ACPI _DSD device properties:
>
>   - Names for GPIO lines
>   - GPIO hogging
>   - Holes in GPIO property lists
>
> We are using these to get Intel Galileo better supported in the mainline
> kernel (but these may be useful for other boards as well). For example SPI
> chip select on Galileo is connected to a GPIO line so we need to be able to
> describe it in ACPI, and at the same time allow native chip selects.
>
> GPIO hogging can be used to set initial state of certain GPIOs available on
> the headers regardless of the BIOS settings (which may be wrong as it knows
> nothing about which devices have been connected).

Awesome!
Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>

>
> The previous version can be found here:
>
>   http://www.spinics.net/lists/linux-acpi/msg69385.html
>
> Changes from v1:
>   - Drop patch [1/5] as it has been applied already.
>   - Move patch [4/5] to be the first.
>   - Rename acpi_data_get_property_reference() to __acpi_node_get_property_reference().
>   - Drop acpi_node_get_property_reference() as it is not necessary anymore.
>   - Add static inline wrapper acpi_node_get_property_reference() that
>     calls the previous passing MAX_ACPI_REFERENCE_ARGS to support existing
>     drivers.
>
> Mika Westerberg (4):
>   ACPI / property: Allow holes in reference properties
>   ACPI / gpio: Add support for naming GPIOs
>   ACPI / gpio: Add hogging support
>   ACPI / gpio: Allow holes in list of GPIOs for a device
>
>  Documentation/acpi/gpio-properties.txt |  62 ++++++++++++++
>  drivers/acpi/property.c                | 117 +++++++++++++++-----------
>  drivers/gpio/gpiolib-acpi.c            | 147 ++++++++++++++++++++++++++++++---
>  include/linux/acpi.h                   |  22 ++++-
>  4 files changed, 285 insertions(+), 63 deletions(-)
>
> --
> 2.9.3
>



-- 
With Best Regards,
Andy Shevchenko

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/4] ACPI / gpio: Updates to properties Mika Westerberg <mika.westerberg@linux.intel.com> - 2016-09-29 15:50 +0200
  [PATCH v2 1/4] ACPI / property: Allow holes in reference properties Mika Westerberg <mika.westerberg@linux.intel.com> - 2016-09-29 15:50 +0200
    Re: [PATCH v2 1/4] ACPI / property: Allow holes in reference properties "Rafael J. Wysocki" <rafael@kernel.org> - 2016-10-11 22:50 +0200
  [PATCH v2 3/4] ACPI / gpio: Add hogging support Mika Westerberg <mika.westerberg@linux.intel.com> - 2016-09-29 15:50 +0200
  [PATCH v2 4/4] ACPI / gpio: Allow holes in list of GPIOs for a device Mika Westerberg <mika.westerberg@linux.intel.com> - 2016-09-29 15:50 +0200
  Re: [PATCH v2 0/4] ACPI / gpio: Updates to properties Andy Shevchenko <andy.shevchenko@gmail.com> - 2016-10-07 19:20 +0200

csiph-web