Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1495922

Re: [RFC][PATCH] cgroup: Add new capability to allow a process to migrate other tasks between cgroups

From Tejun Heo <tj@kernel.org>
Newsgroups linux.kernel
Subject Re: [RFC][PATCH] cgroup: Add new capability to allow a process to migrate other tasks between cgroups
Date 2016-10-05 17:30 +0200
Message-ID <soWiR-2Hq-9@gated-at.bofh.it> (permalink)
References <soIfT-1zP-1@gated-at.bofh.it> <soIpA-1De-17@gated-at.bofh.it> <soKKJ-3lX-5@gated-at.bofh.it> <soM09-4b0-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hello,

On Tue, Oct 04, 2016 at 11:25:29PM -0500, Serge E. Hallyn wrote:
> > > If anything I'd say the GLOBAL_ROOT_UID check could be taken out since
> > > otherwise a host-root task effectively cannot drop this capability.
> > 
> > Is this ok to leave for a separate patch?
> 
> Yeah.  And I'm not sure whether Tejun would object to that idea.

With the capability, I think it'd be better to get rid of the explicit
UID check, but can we please rename the cap to CAP_CGROUP_MIGRATE and
loop in linux-api mailing list and ppl who are more familiar with
CAPs?

Thanks!

-- 
tejun

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[RFC][PATCH] cgroup: Add new capability to allow a process to migrate other tasks between cgroups John Stultz <john.stultz@linaro.org> - 2016-10-05 02:30 +0200
  Re: [RFC][PATCH] cgroup: Add new capability to allow a process to  migrate other tasks between cgroups "Serge E. Hallyn" <serge@hallyn.com> - 2016-10-05 02:40 +0200
    Re: [RFC][PATCH] cgroup: Add new capability to allow a process to  migrate other tasks between cgroups John Stultz <john.stultz@linaro.org> - 2016-10-05 05:10 +0200
      Re: [RFC][PATCH] cgroup: Add new capability to allow a process to  migrate other tasks between cgroups "Serge E. Hallyn" <serge@hallyn.com> - 2016-10-05 06:30 +0200
        Re: [RFC][PATCH] cgroup: Add new capability to allow a process to  migrate other tasks between cgroups Tejun Heo <tj@kernel.org> - 2016-10-05 17:30 +0200

csiph-web