Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1494262
| From | Guenter Roeck <groeck@google.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH v3 1/2] usb: typec: USB Type-C Port Manager (tcpm) |
| Date | 2016-09-30 23:00 +0200 |
| Message-ID | <snd4t-6Ws-1@gated-at.bofh.it> (permalink) |
| References | <s9rh0-140-27@gated-at.bofh.it> <s9rh1-140-55@gated-at.bofh.it> <smZXA-6Lh-9@gated-at.bofh.it> <snbm2-60q-25@gated-at.bofh.it> <snbYJ-6eC-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Sep 30, 2016 at 12:41 PM, Joe Perches <joe@perches.com> wrote:
> On Fri, 2016-09-30 at 12:06 -0700, Guenter Roeck wrote:
>> On Thu, Sep 29, 2016 at 11:37 PM, Jun Li <jun.li@nxp.com> wrote:
> []
>> > diff --git a/include/linux/usb/pd.h b/include/linux/usb/pd.h
> []
>> > +#define PDO_VAR(min_mv, max_mv, max_ma) \
>> > + ((PDO_TYPE_VAR << PDO_TYPE_SHIFT) | \
>> > + ((((min_mv) / 50) & PDO_VAR_MIN_VOLT_MASK) << \
>> > + PDO_VAR_MIN_VOLT_SHIFT) | \
>> > + ((((max_mv) / 50) & PDO_VAR_MAX_VOLT_MASK) << \
>> > + PDO_VAR_MAX_VOLT_SHIFT) | \
>> > + ((((max_ma) / 50) & PDO_VAR_MAX_CURR_MASK) << \
>>
>>
>> ((((max_ma) / 10) & PDO_VAR_MAX_CURR_MASK) << \
>
> This would be easier to read if laid out differently.
>
> #define PDO_VAR(min_mv, max_mv, max_ma) \
> ((PDO_TYPE_VAR << PDO_TYPE_SHIFT) | \
> ((((min_mv) / 50) & PDO_VAR_MIN_VOLT_MASK) << PDO_VAR_MIN_VOLT_SHIFT) | \
> ((((max_mv) / 50) & PDO_VAR_MAX_VOLT_MASK) << PDO_VAR_MAX_VOLT_SHIFT) | \
> ((((max_ma) / 10) & PDO_VAR_MAX_CURR_MASK) << PDO_VAR_MAX_CURR_SHIFT))
>
Code now looks as follows.
#define PDO_VAR_MIN_VOLT(mv) ((((mv) / 50) & PDO_VAR_MIN_VOLT_MASK) << \
PDO_VAR_MIN_VOLT_SHIFT)
#define PDO_VAR_MAX_VOLT(mv) ((((mv) / 50) & PDO_VAR_MAX_VOLT_MASK) << \
PDO_VAR_MAX_VOLT_SHIFT)
#define PDO_VAR_MAX_CURR(ma) ((((ma) / 10) & PDO_VAR_MAX_CURR_MASK) << \
PDO_VAR_MAX_CURR_SHIFT)
#define PDO_VAR(min_mv, max_mv, max_ma) \
(PDO_TYPE(PDO_TYPE_VAR) | PDO_VAR_MIN_VOLT(min_mv) | \
PDO_VAR_MAX_VOLT(max_mv) | PDO_VAR_MAX_CURR(max_ma))
Though maybe I should just ignore line length limits or use shorter defines.
Guenter
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
RE: [RFC PATCH v3 1/2] usb: typec: USB Type-C Port Manager (tcpm) Jun Li <jun.li@nxp.com> - 2016-09-30 09:00 +0200
Re: [RFC PATCH v3 1/2] usb: typec: USB Type-C Port Manager (tcpm) Guenter Roeck <groeck@google.com> - 2016-09-30 21:10 +0200
Re: [RFC PATCH v3 1/2] usb: typec: USB Type-C Port Manager (tcpm) Joe Perches <joe@perches.com> - 2016-09-30 21:50 +0200
Re: [RFC PATCH v3 1/2] usb: typec: USB Type-C Port Manager (tcpm) Guenter Roeck <groeck@google.com> - 2016-09-30 23:00 +0200
Re: [RFC PATCH v3 1/2] usb: typec: USB Type-C Port Manager (tcpm) Joe Perches <joe@perches.com> - 2016-09-30 23:10 +0200
csiph-web