Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1494549
| From | Moshe Green <mgmoshes@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] staging: sm750fb: rename macro roundedDiv to rounded_div in ddk750_chip.c |
| Date | 2016-10-02 12:50 +0200 |
| Message-ID | <snMvf-5IH-9@gated-at.bofh.it> (permalink) |
| References | <snHOV-2Ck-1@gated-at.bofh.it> <snLzb-568-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sun, Oct 02, 2016 at 11:47:47AM +0200, Greg KH wrote: > On Sun, Oct 02, 2016 at 08:48:32AM +0300, Moshe Green wrote: > > Rename CamelCased macro roundedDiv to rounded_div. > > > > This issue was found by checkpatch.pl > > > > Signed-off-by: Moshe Green <mgmoshes@gmail.com> > > --- > > drivers/staging/sm750fb/ddk750_chip.c | 6 +++--- > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > > diff --git a/drivers/staging/sm750fb/ddk750_chip.c b/drivers/staging/sm750fb/ddk750_chip.c > > index 3a0afe1..e4efe91 100644 > > --- a/drivers/staging/sm750fb/ddk750_chip.c > > +++ b/drivers/staging/sm750fb/ddk750_chip.c > > @@ -7,7 +7,7 @@ > > #include "ddk750_power.h" > > > > /* n / d + 1 / 2 = (2n + d) / 2d */ > > -#define roundedDiv(num, denom) ((2 * (num) + (denom)) / (2 * (denom))) > > +#define rounded_div(num, denom) ((2 * (num) + (denom)) / (2 * (denom))) > > Shouldn't you use the in-kernel function for this instead? (I thought briefly of looking for an existing implementation but then chose not to since I wanted to minimize the functional changes in my patches for the time being. Additionally I was wary of using a different implementation for a division operation.) I'll submit a patch that will replace the local implemetaion of rounded division with the in-kernel implementation (I'm assuming you're referring to the DIV_ROUND_CLOSEST macro from include/linux/kernel.h). Thanks Moshe Green
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] staging: sm750fb: rename macro roundedDiv to rounded_div in ddk750_chip.c Moshe Green <mgmoshes@gmail.com> - 2016-10-02 07:50 +0200
Re: [PATCH] staging: sm750fb: rename macro roundedDiv to rounded_div in ddk750_chip.c Greg KH <gregkh@linuxfoundation.org> - 2016-10-02 11:50 +0200
Re: [PATCH] staging: sm750fb: rename macro roundedDiv to rounded_div in ddk750_chip.c Moshe Green <mgmoshes@gmail.com> - 2016-10-02 12:50 +0200
csiph-web