Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1489897
| From | Paolo Bonzini <pbonzini@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] KVM: VMX: refactor global page-sized bitmaps |
| Date | 2016-09-23 11:40 +0200 |
| Message-ID | <skv7z-1Uk-19@gated-at.bofh.it> (permalink) |
| References | <sklrA-4iR-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 23/09/2016 01:18, Radim Krčmář wrote:
> We've had 10 page-sized bitmaps that were being allocated and freed one
> by one when we could just use a cycle and MSR bitmaps had a lot of
> useless code lying around.
>
> This patch
> * enumerates vmx bitmaps and uses an array to store them
> * replaces vmx_enable_intercept_msr_read_x2apic() with a condition
> * joins vmx_msr_disable_intercept_msr_{read,write}_x2apic()
> * renames x2apic_apicv_inactive msr_bitmaps to x2apic and original
> x2apic bitmaps to x2apic_apicv
It's almost like this could be split in four patches! :) Seriously, I
like it very much but it's very hard to review.
Also, while it's a good idea to keep the bitmaps in an array,
vmx_bitmaps[vmread_bitmap] is not very readable. Please make the enum
uppercase, and possibly add
#define vmread_bitmap (vmx_bitmaps[VMREAD_BITMAP])
Thanks!
Paolo
> Signed-off-by: Radim Krčmář <rkrcmar@redhat.com>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] KVM: VMX: refactor global page-sized bitmaps Radim Krčmář <rkrcmar@redhat.com> - 2016-09-23 01:20 +0200
Re: [PATCH] KVM: VMX: refactor global page-sized bitmaps Paolo Bonzini <pbonzini@redhat.com> - 2016-09-23 11:40 +0200
Re: [PATCH] KVM: VMX: refactor global page-sized bitmaps Wanpeng Li <kernellwp@gmail.com> - 2016-09-23 11:50 +0200
Re: [PATCH] KVM: VMX: refactor global page-sized bitmaps Radim Krčmář <rkrcmar@redhat.com> - 2016-09-27 16:20 +0200
csiph-web