Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1489616

Re: [PATCH v5 2/6] x86/arch_prctl/64 Rename do_arch_prctl to do_arch_prctl_64

From Andy Lutomirski <luto@amacapital.net>
Newsgroups linux.kernel
Subject Re: [PATCH v5 2/6] x86/arch_prctl/64 Rename do_arch_prctl to do_arch_prctl_64
Date 2016-09-23 00:20 +0200
Message-ID <skkvv-3IV-25@gated-at.bofh.it> (permalink)
References <sjUUp-4cs-9@gated-at.bofh.it> <sjV45-4uN-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Sep 21, 2016 at 11:58 AM, Kyle Huey <me@kylehuey.com> wrote:
> In order to introduce new arch_prctls that are not 64 bit only, rename the
> existing 64 bit implementation to do_arch_prctl_64. Also rename the second
> argument to arch_prctl, which will no longer always be an address.

Reviewed-by: Andy Lutomirski <luto@kernel.org>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v5 0/6] x86/arch_prctl Add ARCH_[GET|SET]_CPUID for controlling the CPUID instruction Kyle Huey <me@kylehuey.com> - 2016-09-21 21:00 +0200
  [PATCH v5 6/6] x86/arch_prctl Add ARCH_[GET|SET]_CPUID Kyle Huey <me@kylehuey.com> - 2016-09-21 21:10 +0200
    Re: [PATCH v5 6/6] x86/arch_prctl Add ARCH_[GET|SET]_CPUID Andy Lutomirski <luto@amacapital.net> - 2016-09-23 00:30 +0200
      Re: [PATCH v5 6/6] x86/arch_prctl Add ARCH_[GET|SET]_CPUID Kyle Huey <me@kylehuey.com> - 2016-09-26 22:00 +0200
  [PATCH v5 2/6] x86/arch_prctl/64 Rename do_arch_prctl to do_arch_prctl_64 Kyle Huey <me@kylehuey.com> - 2016-09-21 21:10 +0200
    Re: [PATCH v5 2/6] x86/arch_prctl/64 Rename do_arch_prctl to do_arch_prctl_64 Andy Lutomirski <luto@amacapital.net> - 2016-09-23 00:20 +0200
  [PATCH v5 1/6] x86/arch_prctl/64 Use SYSCALL_DEFINE2 to define sys_arch_prctl Kyle Huey <me@kylehuey.com> - 2016-09-21 21:10 +0200

csiph-web