Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1488396
| From | Josh Poimboeuf <jpoimboe@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v2 0/9] x86/entry/head: standardize the end of the stack |
| Date | 2016-09-21 23:10 +0200 |
| Message-ID | <sjWWd-5EH-5@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
v2: - keep 'restore_all' label in "x86/entry/head/32: use local labels" --- Thanks to all the recent x86 entry code refactoring, most tasks' kernel stacks start at the same offset right below their saved pt_regs, regardless of which syscall was used to enter the kernel. That creates a nice convention which makes it straightforward to identify the end of the stack, which can be useful [*] for the unwinder. But there a few places where tasks don't yet follow the convention. This patch set finishes the job. [*] This will be useful for three upcoming proposed features: - Detecting corrupt stacks in the unwinder (which will also be a force for ensuring this end of stack convention continues to be followed in the future). - Printing all saved pt_regs on the stack during an oops/warning. - Validating stacks in the livepatch consistency model. Josh Poimboeuf (9): x86/entry/head/32: use local labels x86/entry/32: rename 'error_code' to 'common_exception' x86/entry/32: fix the end of the stack for newly forked tasks x86/head/32: fix the end of the stack for idle tasks x86/smp: fix initial idle stack location on 32-bit x86/asm/head: use a common function for starting CPUs x86/head: put real return address on idle task stack x86/head: fix the end of the stack for idle tasks x86: move _stext marker to before head code arch/x86/entry/entry_32.S | 108 +++++++++++++++++++++++++----------------- arch/x86/kernel/head_32.S | 49 +++++++++++-------- arch/x86/kernel/head_64.S | 42 ++++++++-------- arch/x86/kernel/smpboot.c | 4 +- arch/x86/kernel/vmlinux.lds.S | 2 +- 5 files changed, 116 insertions(+), 89 deletions(-) -- 2.7.4
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v2 0/9] x86/entry/head: standardize the end of the stack Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200 [PATCH v2 1/9] x86/entry/head/32: use local labels Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200 [PATCH v2 2/9] x86/entry/32: rename 'error_code' to 'common_exception' Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200 [PATCH v2 4/9] x86/head/32: fix the end of the stack for idle tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200 [PATCH v2 6/9] x86/asm/head: use a common function for starting CPUs Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200 [PATCH v2 7/9] x86/head: put real return address on idle task stack Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200 [PATCH v2 3/9] x86/entry/32: fix the end of the stack for newly forked tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200 [PATCH v2 8/9] x86/head: fix the end of the stack for idle tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 23:10 +0200
csiph-web