Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1487744
| From | Andy Lutomirski <luto@amacapital.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/9] x86/entry/head/32: use local labels |
| Date | 2016-09-21 03:00 +0200 |
| Message-ID | <sjE3f-1Wa-7@gated-at.bofh.it> (permalink) |
| References | <sjzwB-7F4-3@gated-at.bofh.it> <sjzwD-7F4-85@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sep 20, 2016 10:03 AM, "Josh Poimboeuf" <jpoimboe@redhat.com> wrote: > > Add the local label prefix to all non-function named labels in head_32.S > and entry_32.S. In addition to decluttering the symbol table, it also > will help stack traces to be more sensible. For example, the last > reported function in the idle task stack trace will be startup_32_smp() > instead of is486(). > I think that restore_all, at least, should stay. It's a common tail for lots of functions. I haven't checked this patch for other cases where the new label is worse than the old for debugging. --Andy
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/9] x86/entry/head: standardize the end of the stack Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
[PATCH 2/9] x86/entry/32: rename 'error_code' to 'common_exception' Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
[PATCH 6/9] x86/asm/head: use a common function for starting CPUs Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
[PATCH 3/9] x86/entry/32: fix the end of the stack for newly forked tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
Re: [PATCH 3/9] x86/entry/32: fix the end of the stack for newly forked tasks Brian Gerst <brgerst@gmail.com> - 2016-09-21 03:20 +0200
Re: [PATCH 3/9] x86/entry/32: fix the end of the stack for newly forked tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 05:30 +0200
Re: [PATCH 3/9] x86/entry/32: fix the end of the stack for newly forked tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 05:40 +0200
Re: [PATCH 3/9] x86/entry/32: fix the end of the stack for newly forked tasks Andy Lutomirski <luto@amacapital.net> - 2016-09-21 08:50 +0200
Re: [PATCH 3/9] x86/entry/32: fix the end of the stack for newly forked tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 13:40 +0200
[PATCH 9/9] x86: move _stext marker to before head code Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
[PATCH 7/9] x86/head: put real return address on idle task stack Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
[PATCH 4/9] x86/head/32: fix the end of the stack for idle tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
[PATCH 5/9] x86/smp: fix initial idle stack location on 32-bit Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
[PATCH 1/9] x86/entry/head/32: use local labels Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
Re: [PATCH 1/9] x86/entry/head/32: use local labels Andy Lutomirski <luto@amacapital.net> - 2016-09-21 03:00 +0200
Re: [PATCH 1/9] x86/entry/head/32: use local labels Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-21 05:00 +0200
[PATCH 8/9] x86/head: fix the end of the stack for idle tasks Josh Poimboeuf <jpoimboe@redhat.com> - 2016-09-20 22:10 +0200
csiph-web