Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1485175

Re: [PATCH 2/2] phy: msm8996-pcie-phy: Add support to msm8996 pcie phy

From Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH 2/2] phy: msm8996-pcie-phy: Add support to msm8996 pcie phy
Date 2016-09-16 18:50 +0200
Message-ID <si4uR-7hN-11@gated-at.bofh.it> (permalink)
References <seIKd-765-3@gated-at.bofh.it> <seIKd-765-1@gated-at.bofh.it> <si29I-5Pq-43@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



On 16/09/16 15:14, Stanimir Varbanov wrote:
>> > +	writel_relaxed(0x0f, base + QSERDES_COM_BG_TRIM);
>> > +	writel_relaxed(0x0f, base + QSERDES_COM_PLL_IVCO);
>> > +	writel_relaxed(0x19, base + QSERDES_COM_CLK_EP_DIV);
>> > +	writel_relaxed(0x10, base + QSERDES_COM_CLK_ENABLE1);
>> > +	writel_relaxed(0x00, base + QSERDES_COM_HSCLK_SEL);
>> > +	writel_relaxed(0x40, base + QSERDES_COM_RESCODE_DIV_NUM);
>> > +	writel_relaxed(0x00, base + PCIE_COM_SW_RESET);
>> > +	writel_relaxed(0x03, base + PCIE_COM_START_CONTROL);
> I'd make an array with register/value pair and write the registers with
> a for () loop. IMO it will be more readable.
>
> Probably 3 arrays - power_on, power_on_common and power_off.
Thats good idea, I will keep that in mind before sending next version 
with common phy driver for USB/PCIE/UFS.

thanks
srini

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

Re: [PATCH 2/2] phy: msm8996-pcie-phy: Add support to msm8996 pcie  phy Stanimir Varbanov <stanimir.varbanov@linaro.org> - 2016-09-16 16:20 +0200
  Re: [PATCH 2/2] phy: msm8996-pcie-phy: Add support to msm8996 pcie  phy Srinivas Kandagatla <srinivas.kandagatla@linaro.org> - 2016-09-16 18:50 +0200

csiph-web