Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1482172

Re: [PATCH] s390: cleanup with list_first_entry_or_null()

From Heiko Carstens <heiko.carstens@de.ibm.com>
Newsgroups linux.kernel
Subject Re: [PATCH] s390: cleanup with list_first_entry_or_null()
Date 2016-09-13 08:50 +0200
Message-ID <sgPHz-6Bw-3@gated-at.bofh.it> (permalink)
References <sgDZL-6Vq-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Sep 13, 2016 at 03:10:39AM +0900, Masahiro Yamada wrote:
> The combo of list_empty() check and return list_first_entry()
> can be replaced with list_first_entry_or_null().
> 
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
> ---
> 
>  arch/s390/kernel/crash_dump.c | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/s390/kernel/crash_dump.c b/arch/s390/kernel/crash_dump.c
> index 29df848..621907d 100644
> --- a/arch/s390/kernel/crash_dump.c
> +++ b/arch/s390/kernel/crash_dump.c
> @@ -71,9 +71,8 @@ struct save_area * __init save_area_alloc(bool is_boot_cpu)
>   */
>  struct save_area * __init save_area_boot_cpu(void)
>  {
> -	if (list_empty(&dump_save_areas))
> -		return NULL;
> -	return list_first_entry(&dump_save_areas, struct save_area, list);
> +	return list_first_entry_or_null(&dump_save_areas, struct save_area,
> +					list);

Applied, however without the line break in order to improve readability.

Thanks!

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH] s390: cleanup with list_first_entry_or_null() Masahiro Yamada <yamada.masahiro@socionext.com> - 2016-09-12 20:20 +0200
  Re: [PATCH] s390: cleanup with list_first_entry_or_null() Heiko Carstens <heiko.carstens@de.ibm.com> - 2016-09-13 08:50 +0200

csiph-web