Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1479506
| Path | csiph.com!feeder.erje.net!1.us.feeder.erje.net!newsfeed.fsmpi.rwth-aachen.de!newsfeed.straub-nv.de!news.unit0.net!news.panservice.it!bofh.it!news.nic.it!robomod |
|---|---|
| From | Kees Cook <keescook@chromium.org> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/2] ramoops: use buffer_size() and buffer_start() |
| Date | Thu, 08 Sep 2016 22:50:02 +0200 |
| Message-ID | <sfeqK-2at-37@gated-at.bofh.it> (permalink) |
| References | <sbQkW-4K2-27@gated-at.bofh.it> <sbQkW-4K2-25@gated-at.bofh.it> |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=20120113; h=mime-version:sender:in-reply-to:references:from:date:message-id :subject:to:cc; bh=2JjdGZ2ojmQ9n7ZnzKW0dUPB8HZcWvAxTY1ViFAShnA=; b=eQsQ61uZSoMyhTGiSgwN0IgoTmMVZbV78Rt9bUcjjOo+/L0AeFbMCctCxiuD4Qodbv JBKWqjlKe4jyfVOrDdoRMAmmyEyP76/dF5QYzrJfrGlhMseS+p150UUxdm3QgQ2zU+lp FiJfPDVJjvBXvQh1yBkyB4ynlVYYQnYtoj3kN6qmSJhrh39uqHVVdTJBk1Gt6LlCDueH 2FFavtn+bIx+UJGB4I6o1b/ofZxbLG4vdnzK4O7Pyi6MMA6Jz/NuKswQeSVgUJup9n3L iwb1Mc87EyYJdTFaKHMy4XZSG/LHwlzl4G1dCNKp+H367jDDDejQHQgS120pOn1Isa35 VWNQ== |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=chromium.org; s=google; h=mime-version:sender:in-reply-to:references:from:date:message-id :subject:to:cc; bh=2JjdGZ2ojmQ9n7ZnzKW0dUPB8HZcWvAxTY1ViFAShnA=; b=U+3pNReM3hxSj2XSCbXz8Uv8aZ41QUnbpQkE+iMKzJfA+smJ+NE4f/M3K/zeUNIZco BFnEQqRHh21DvXoDpbd4+L7RnURFoy4SNuIpMuCNz/sEtoIPOVjhqZjYqY5mDOw6Wp1i 1T9CnC1zVjznPZxAMW5M9VsKMX8+rNVcZ9kCU= |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:mime-version:sender:in-reply-to:references:from :date:message-id:subject:to:cc; bh=2JjdGZ2ojmQ9n7ZnzKW0dUPB8HZcWvAxTY1ViFAShnA=; b=H4UpAtGDY+zmBZiGhHxg9jpTKrB1aT2W4RBb+lpKZHlBVcLEkn8mBuzObAXnnVBRYL aDMnQq+XDWYoaOFK3rqpA0N4ogoW7J1JgoAVD++kvtqE8Bs4cw1JfT3rgMBhU5XfSQ80 0+nUQ260l6+UnOwSCvZgQPwHbDcuhSWsM8eoJBGzuuKvExc8E6pMRaxOyr9yU0IVSyCf 6DosMHhR+IDveR+UjPg81HeGzoFQkoaHYyK8gadA+VTIYYcp/50Q8TZDkJLjzkozlVnQ ALCL+GSthEERRbGheBYcqOVK7zu0o2+njGSwlZnhaQpPRNtLGlc3tp5SJ+HN0ZkJcKeN ACAA== |
| X-Gm-Message-State | AE9vXwM3Ds/HJPYfPFkXaLIv+W3l8fDB6uwoViKnCTcY9allbvZUn+DFevbo4QysC9EphMiDvJDwXWdf+K/bGHVo |
| X-Received | by 10.159.38.9 with SMTP id 9mr1354943uag.103.1473367472000; Thu, 08 Sep 2016 13:44:32 -0700 (PDT) |
| MIME-Version | 1.0 |
| X-Google-Sender-Auth | 0VtF_ZlzJtM_a77qZekC9GjoASs |
| Content-Type | text/plain; charset=UTF-8 |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 73 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Anton Vorontsov <anton@enomsg.org>, Colin Cross <ccross@android.com>, Tony Luck <tony.luck@intel.com>, LKML <linux-kernel@vger.kernel.org> |
| X-Original-Date | Thu, 8 Sep 2016 13:44:31 -0700 |
| X-Original-Message-ID | <CAGXu5jJLvrCxTMBs0O5SS1pbH8gc6aqcDMr6nmPL8XhNC0u30A@mail.gmail.com> |
| X-Original-References | <12fb7f17b91d55f53e7aa437e9a25d708a24732c.1472559626.git.geliangtang@gmail.com> <984a112e60904a7bbbe046c5d9d2c1f10dfe02b6.1472559626.git.geliangtang@gmail.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1479506 |
Show key headers only | View raw
On Tue, Aug 30, 2016 at 5:24 AM, Geliang Tang <geliangtang@gmail.com> wrote:
> Since buffer_size() and buffer_start() have been defined in ram_core.c,
> use them instead of open-coding.
>
> Signed-off-by: Geliang Tang <geliangtang@gmail.com>
Hi!
Thanks for this clean-up. However, since the _atomic method has been
removed entirely now, I don't want to make this change, since it makes
reading the atomic_read/atomic_set in functions unmatched. I'd prefer
to leave this as-is.
-Kees
> ---
> fs/pstore/ram_core.c | 10 +++++-----
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/fs/pstore/ram_core.c b/fs/pstore/ram_core.c
> index 76c3f80..a8500cd 100644
> --- a/fs/pstore/ram_core.c
> +++ b/fs/pstore/ram_core.c
> @@ -54,7 +54,7 @@ static size_t buffer_start_add_atomic(struct persistent_ram_zone *prz, size_t a)
> int new;
>
> do {
> - old = atomic_read(&prz->buffer->start);
> + old = buffer_start(prz);
> new = old + a;
> while (unlikely(new >= prz->buffer_size))
> new -= prz->buffer_size;
> @@ -69,11 +69,11 @@ static void buffer_size_add_atomic(struct persistent_ram_zone *prz, size_t a)
> size_t old;
> size_t new;
>
> - if (atomic_read(&prz->buffer->size) == prz->buffer_size)
> + if (buffer_size(prz) == prz->buffer_size)
> return;
>
> do {
> - old = atomic_read(&prz->buffer->size);
> + old = buffer_size(prz);
> new = old + a;
> if (new > prz->buffer_size)
> new = prz->buffer_size;
> @@ -91,7 +91,7 @@ static size_t buffer_start_add_locked(struct persistent_ram_zone *prz, size_t a)
>
> raw_spin_lock_irqsave(&buffer_lock, flags);
>
> - old = atomic_read(&prz->buffer->start);
> + old = buffer_start(prz);
> new = old + a;
> while (unlikely(new >= prz->buffer_size))
> new -= prz->buffer_size;
> @@ -111,7 +111,7 @@ static void buffer_size_add_locked(struct persistent_ram_zone *prz, size_t a)
>
> raw_spin_lock_irqsave(&buffer_lock, flags);
>
> - old = atomic_read(&prz->buffer->size);
> + old = buffer_size(prz);
> if (old == prz->buffer_size)
> goto exit;
>
> --
> 2.7.4
>
--
Kees Cook
Nexus Security
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 2/2] ramoops: use buffer_size() and buffer_start() Geliang Tang <geliangtang@gmail.com> - 2016-08-30 14:30 +0200 Re: [PATCH 2/2] ramoops: use buffer_size() and buffer_start() Kees Cook <keescook@chromium.org> - 2016-09-08 22:50 +0200
csiph-web